Lighthouse returned error: NO_FCP. The page did not paint any content

I am getting the following error message from Google Page Speed (as part of the Google Site Kit plugin) :–

“Error: Lighthouse returned error: NO_FCP. The page did not paint any content. Please ensure you keep the browser window in the foreground during the load and try again. (NO_FCP)”

I don’t understand what’s happening here. Can you shed any light on this and what I can do to correct it?
My URL is in the Secure Note.

Hi Arif,

Thanks for reaching out!

There could be a plugin or custom code that affects the result in Google Page Speed.

I recommend the following troubleshooting procedures before we investigate the settings.


Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi ,

It may (or may not) have been caused by CDN & Cache plugin misconfigurations / conflicts. I was experimenting with a combined use of Cloudflare CDN plugin, Litespeed Cache plugin and WP Cloudflare Super Page Cache plugin - as per the instructions in this article: . The problem started during use or after I uninstalled these plugins - I don’t exactly recall. i also use The “Site Kit” plugin by Google which bundle Analytics, Page Speed, Search Console etc services by Google. The Page Speed in the “Site Kit” plugin was showing the above mentioned error. Page Speed Insights in Google Developer site was also showing the same error - since the last day or two. I re-installed the main Clouflare CDN plugin and WP Cloudflare Super Page Cache plugin a little while ago and since then Page Speed Insights in Google Developer site started to work albeit giving a VERY VERY LOW performance score. But the Page Speed inside the Site Kit plugin still kept showing the error message!

I have followed the first two troubleshooting procedures so far that you have recommended. In fact I started with disabling even Cornerstone - along with all others and switching to Wordpress Twenty-Twenty One theme. That gave me a performance score of 93 in Page Speed Insights in Google Developer site. Then I activated Cornerstone ( along with X Child Theme) - which lowered my performance score quite a bit in Page Speed Insights in Google Developer site . Then I re-installed the Cloudflare CDN along with the WP Cloudflare Super Page Cache plugin (without enabling the ‘cache’ option in it). This brought my score in the outside PageSpeed to somewhere between 63-66. Then I re-installed Site Kit plugin again. This lowered my performance score in external Page Speed to 40. Then I UN-INSTALLED Site-Kit once again. Right away the performance score in external Page Speed scan from Google developer site shot up to 69 from 40!!

I haven’t carried out the last 3 troubleshooting procedures you mentioned, but to me it looks like there is something wrong with the Site-Kit plugin itself. Maybe this is the main culprit - at least along with something else! What do you think???

Do you think I need to carry out the other troubleshooting steps any longer or just re-install Site-Kit or switch to another similar pluging? What do you think I should do now?

Thank you.

Hi ,

I have re-activated ALL existing plugins now and it has brought down the performance score in the external Page Speed Insights scan to 27 - from 69 as mentioned in the last step of my previous post. And it’s slowly getting lower. The Page Speed scan inside the Site Kit plugin still keeps showing the said error message though!!

NOTE: I just discovered a lot of ERROR messages in the WIDGET section (Appearance > Widgets) of the Wordpress backend dashboard. I’ve uploaded a screenshot of it in the cloud. Please find a link to the uploaded screenshot in the Secure Note section below.

Hi Arif,

Having multiple caching plugins/features can actually hurt a site’s performance than do good if not configured properly.

The error above is with the 3rd party plugin Google Site Kit plugin which we can not provide support about, regretfully, so you need to contact their support. There is the possibility that this is also related to having multiple caching features.

Regarding that widget issue, I think I saw that same issue before and it causes by another plugin (can’t remember what plugin was that though), please do a test for plugin conflict again to determine what is causing that errors, again this could also be related to your multiple caching features setup.


Hi friech ,

It’s X’s “Cornerstone” plugin that’s causing the widget errors! I conducted 2 rounds of plugin tests. During the first round I deactivated ALL plugins and then started re-activating them from the top of the list one by one and checking every time whether the last activated plugin is generating any error messages in the Widget area. It was Cornerstone which first and mostly generated the Widget errors. A couple of other plugins also generated errors after that - but 2 or 3 errors at most. But Cornerstone generated 9 errors.
During the second round of testing I again deactivated ALL plugins. Then I re-activated and de-activated the plugins individually, i.e. re-activated them individually, checked whether it’s causing any Widget errors on its own, then deactivated it and re-activated a new one. In this test I found that no plugins are causing any errors, EXCEPT “Cornerstone”. Cornerstone causes those errors, and a lot of them, irrespective of whether any other plugin is turned on or not!!

Please advise what to do next!

Hi Arif,

I have followed your steps in the local environment, but unfortunately, I am not able to replicate the issue you described here. I would suggest you check by activating any of the default themes like TwentyTwenty and check if that works for you. Please deactivate and activate the Cornerstone with the default theme to confirm that it is the cause of your issue.
If the issue does not exist with the default theme, please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Just wanting to follow this thread.

Hi @FourCandles,

If you are having the same issue, I would suggest you go through the above process and let us know if that helps you. If not, please create a separate thread and please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Hi tristup,

I followed your suggestions.

I …

  1. Switched the theme to default “Twenty Twenty-One”

  2. Deactivated ALL plugins
    RESULT - 1 = No error messages any longer in the Widget area. All clean!
    (Ref: Picture - 1 in Secure Note)

  3. Re-activated ONLY Cornerstone ( theme: default “Twenty Twenty-One”)
    RESULT - 2 = Lot of errors again + Error establishing database connection
    (Ref: Pictures - 2 & 3 in Secure Note)

I uploaded all the pictures in pCloud and provided the links in Secure Note below.

I am trying to set up a staging site for you in a Subdomain.

Hello @monmajhi,

Please let us know when the staging site is ready.


Hi prakash_s ,

Sorry, the staging site is going to be delayed. While trying to create the staging site, for some reason I lost access to both my main site and the newly created subdomain. With the help of the hosting provider’s support staff I recovered the subdomain, but the main is still remains problematic. Originally the wp login page was not appearing and instead re-directing to the homepage again and again. It was solved by disabling the .htaccess file. But this is causing additional errors inside the wp admin area. Now the hosting provider’s support staff is asking me to find a line inside the htaccess file that was redirecting me from the wp login screen to homepage. But this is beyond me. Her alternative suggestion is she can create a new default htaccess. Problem is I have no idea what would be the impact of it on my site, the theme, plugins, settings etc. What do you think? Should I create a new default htaccess?? And can I then clone the main site to the subdomain staging site? Will that be suitable for you to work / test on?? I don’t know what to do at this moment!

Hey Arif,

Sorry for the confusion. It is best that you set up staging but not for this case because of the following reasons:

  1. NO_FCP is not because of any theme and/or builders including ours. It could be a false report in the Site Kit plugin only. I ran your site in the Pagespeed Insights by Google and there’s no NO_FCP issue.

Please contact the Site Kit plugin support as to why the result in the plugin is different than the actual Pagespeed Insights tool.

I also ran your site on the browser’s Lighthouse tool and there’s also NO_FCP.

  1. You need to understand what FCP or First Contentful Paint is. There are many factors that contribute to the paint and the first is the server’s response time. That means it’s your web host.

The reason why you get high score when you deactivate Cornerstone is that you don’t have content because you built the content using Cornerstone.

The 2 remaining suggestions which are Eliminate render-blocking resources and Reduce unused CSS are beyond the scope of theme support to discuss as you’d need to configure optimization plugins for that. We have a general guide on Website Performance here but note that we cannot provide help for optimization issues. We can only answer customization including 3rd party plugin setup questions in our One plan


Hi christian ,

Finally, the Staging Site is up and running. Whew!! And now I notice your reply!!!

In any case, why are “Widget” errors like – “The “archives” block was affected by errors and may not function properly. Check the developer tools for more details.” - are happening? Is it in any way related to the theme or the plugins that came with it or falls within the scope of theme support?

Hey Arif,

For the Widget error, please give us staging WP and staging FTP access so we could see if the issue is really coming from Cornerstone. Give us the following details in a Secure Note

  • Staging WordPress Login URL
  • Admin username and password
  • Staging FTP credentials (please ask your web host if you’re not familiar with this)



I don’t see Secure Note’s ‘key’ symbol beneath your post! Oh, ok, I see one beneath my post though. Please find the necessary info in Secure Note below.

Hoping for a speedy action. Please do let me know here when you are done.


Hi Arif,

I have checked your website and found the issue you described earlier. It might be an issue with WordPress latest version, I have checked it with the default theme and found the issue exists. I have also found that the issue is already reported to the WordPress for further investigation, and as suggested please use the Classic Widget plugin for now to avoid the issue temporarily.

I went ahead and installed the said plugin and found that the Widget are working as previous.


Thanks Tristup, the Classic Widget works. :+1:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.