Layout Builder archives layout completely gone

I had two layouts built for two separate archive post types, and they are in the Cornerstone list, but the content is completely gone. The live page now says “Unable to Locate Global Block”. When trying to edit the layout, I have to start from scratch. Any idea what could have happened?

The Wordpress core auto updated to 6.2, so I removed the Pro folder from files and uploaded a newer version. Still no fix. I then rolled back the site to a previous version before the auto update and disabled auto core updates for the time being. Still no fix.

I’m happy to provide login credentials if you might know what happened?

Hello @turnkeydigital,

Thanks for writing to us.

In order to help you with your concerns we need to check your settings I would request you, please share the admin login details meanwhile I would suggest you troubleshoot a few of the common issues before we investigate your settings. Please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin-level username and password
  • Exact layout URL

You can find the Secure Note button at the bottom of your posts


Thanks for your reply. I’ve provided login credentials in a secure note.

The exact error pages are:

I’ve also gone through all of the points in the troubleshooting checklist. The Archive layouts are still showing empty.

Hello @turnkeydigital,

I can see that you have this in your child theme.

When I double-check to find the global block or the Component because that is the new name in the latest versions, I am now seeing nothing. Just this one:

Did you use Pro 5.x or later when you build this site?


Yes, I used the Layout Builder in an updated version of Pro… it was surely at least 5.x

When Components were added, the layout content has disappeared. How do you suggest we fix this?

There are two post types, a “Case Studies” post type, and the “News” post type. I’m sure when this site was initially built it was using the data from the archive.php file, however, the News Archive was solely built with the Archive Layout builder within Pro, and the layout was assigned to the News post type.

Global Blocks are now called ‘Components’ and that’s great, but where did all the content go within the Layout Builder?

I haven’t heard a response on this, and it’s odd I’m finding older threads with this same issue.

I exported a similar layout from a sister site and imported into my archive templates. I shouldn’t have had to do this, but response was dragging and this issue was on a live site. I couldn’t find any reference to my old archive layout within my files, so this was my best option. The other option would have been to completely rebuild those layouts.

Please update if you find any cause for a completely empty archive layout. Thanks

I think you might have the post type change issue. Due to a plugin it probably stripped content as it changed the post type. It’s happened a couple of times which makes me think the Raw SQL migration laid out in the following docs should be the default migration strategy. That login didn’t work, but let me know if this doesn’t sound right I can check the site as well. Thanks and let me know if this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.