Latest Updates Have Broken WP Dash, Visual Elements, Layout and Fonts


Your previous reply does not seem to make sense. Please can you re-write it? I’m afraid this isn’t of any help!


Hi @paulcarpenterfilms,

Sorry for the confusion, sure, I’ll explain it below :slight_smile:

I checked it through FTP and there is no error, but rather, just warnings related to the slider. Which of course, nothing to do with menu issue.

Perhaps the menu and update that you’re referring were accidentally deleted. Like going to Appearance > Menus and deleted it, and accidentally saved it. I’m not saying you did but could be someone with access to it. Other than accidental, it can only be deleted by intentionally added code or plugin which aren’t present at your site.

Then I recommend adding those missing menu items again, but my question is, are those menu related to specific pages and deleted as well?

Regarding restoring a working version, sadly my last stored backup was made before extensive changes were made and so is too far out of date. I have a recent backup but this was made after these problems occured so there are possibly issues embedded within the backup.

I agree if this issue is present even before the migration of backup then restoring it will have the same result. The only solution as of now is re-creating and re-adding them.


Hi, Sorry but I think you have misunderstood the problem.

The site menus are fine. If elements were missing from those, that would be an easy fix.

My problem, which ultimately led to all the visual issues and broken store, is that the ‘Home’ and ‘Updates’ options are missing from the WORDPRESS menu.

In the image below you will see a screenshot of my WP dashboard with the new version of X installed on my Musicmanproject site:

You can see that in the black WP menu to the left of the screen the ‘Home’ and ‘Updates’ options are missing. This means I no longer have the option of updating my themes and plugins.

In the next screenshot, taken of the WP dashboard of one of my OTHER websites NOT using X:

…So you should see in the above image that ‘updates’ appears as expected, in the black WP dashboard menu on the left.

As I mentioned in a previous reply, to test this further I made a new subdomain, installed latest versions of X and Wordpress but did not import any site content. The problem still persists - there is no option to update in the black WP dashboard menu.

I look forward to hearing your thoughts…

Hello @paulcarpenterfilms,

Is Music Man Project site one of your network sites? Do you have multi site set up? If you do, the updates will be in My Sites > Network Admin > Dashboard.

And if ever you are only having one site set up, then one of the plugins must be causing the conflict removing some of the menu items. There must be something going on or a restriction has made to your set up because the theme editor (Appearance > Editor), add new plugin and even the plugin editor menu links is also missing.

Please let us know how it goes.


As I mentioned previously, I have tried deactivating all plugins on but it does not fix the problem.

I have a shared hosting plan on GoDaddy. The Music Man Project is one of three sites hosted there and all are managed via Cpanel. The other two sites are also Wordpress but do not run X theme. They are working fine.

X used to run fine on themusicmanproject - until these recent updates. I believe these issues are definitely related to the latest version of Wordpress in combination with the latest X.

Can you help? I am out of ideas on this but this is a very important client so I need a fix.

Hi @paulcarpenterfilms,

May we have the permissions to put your site under construction and be able to test for another round of plugin conflict? Maybe we can switch to another theme and check if the theme is causing it or not.

Please let us know what you think.


Yes, please go ahead and put the site under construction to check the plugins further. I am grateful for your help with this.

Please can I ask you return the site to its current working state as soon as you can after completing the checks.

Thanks in advance.

Hi @paulcarpenterfilms,

Thanks for previous clarification. I did the testing without X theme and cornerstone and those updates and home menu items are still missing. Even all the plugins are deactivated, the result is still the same.

This means it’s not related to the theme and plugin updates, could you try logging in with a different account? Maybe it’s due to account permission.


Hi, Thank you.

I have just tried logging in with the credentials I use for the other two Wordpress sites I have on the same hosting, but that didn’t work. The only way I can get into my Musicmanproject dashboard is with those credentials you have been using to test.

Is it possible there is some kind of permissions-related file on the server which may have become corrupt? Is there anything else related to the server or CPanel that might affect permissions in X on Wordpress?


Hello @paulcarpenterfilms,

Maybe there are file permission issues in your server. When file editing or file permission exist, you won;t be able to update or edit any files of the theme or plugin in the dashboard. You might need to check this:

Hope this helps.

Thanks. I’m not sure the article on disabling automatic updates is particularly relevant in terms of fixing any permission issues if they exist. If you remember from previous replies, I do not have ‘appearance’ or ‘plugins’ in my WPdash either, ao I guess the problem goes deeper than that?

Do you think this issue is something I need to contact GoDaddy about again? I have already done so three times but they were completely unwilling to help.

If I were to install WP and X on a new ‘test’ subdomain then find out how to restore a recent musicmanproject database to that test domain, could that work? Or would this just restore the inherent problem? Also, if I did this, I don’t think my X license wouldn’t be valid as it is still active on the current MMP website, which I cannot take down until there is a fully working replacement.


Hey @paulcarpenterfilms,

If you’re in a managed WordPress host, their support should be able to help you with WordPress problems. As Rad has tested, this is not an issue with our products as even deactivating it, the issue still persists.

But, you can double check this again by creating another test site/subdomain and install a clean recent version of WordPress. Do not install X at this point. Check first if the Home and Updates menus are available under the Dashboard menu. If it’s not available then this is really not an issue with our products.

If the said menus are available, install X next and then after activating, check again if they’re still available under the Dashboard menu. This will tell us if X is causing the issue. If this is the case, please give us WordPress Admin and FTP access to the new staging/test site. If the menus are still present after installing X, the cause could be different and we also could not help if that is the case.

By the way, each license of X and Pro allows for 1 production and 1 staging site. Register your staging domain so you’ll be able to update X there.

For more details, please see


Ok, thank you. I have set up a test domain with clean install of WP and X (validated). It has no other content and the WP menu displays correctly.

It’s a shame you couldn’t help with my question about restoring the MMP site database on the new test domain. Godaddy refuse to help as well due to what they call a ‘change of policy’ regarding Wordpress support.

Hi there,

Sorry to hear that, yes, we couldn’t cover any hosting and site management issue as well as we have no full control over it. With that, I recommend contacting a webmaster that may able to help you restore the working copy of database and files.

Thanks for understanding.

Thanks for the input you have given. It is very frustrating that this problem remains unresolved though. The backend is still broken.

I stand by my opinion that whatever issue originally broke the Wordpress installation was linked to latest X, Cornerstone and WP updates.

I guess it looks like I will need to learn how to fix things within the installation and database before the site innevitably goes down again…

Hello @paulcarpenterfilms,

We understand your frustration. As we have said, this issue has something to do with your server’s file permission by which only your hosting provider can resolved. Please understand that after the update as you have said, the Dashboard, Home and Updates were missing. You cannot upload a theme or add a new plugin either.

So I went ahead and logged to our ftp again and investigated most of your WP files. I found out that there is a restriction added in your wp-config.php file.

define('DISALLOW_FILE_EDIT', true);
define('DISALLOW_FILE_MODS', true);

I have removed the lines and here it is. The Dashboard, Home, Updates, Add A New Theme, Theme Editor, Add new plugin and the Plugin Editor is back right in your dashboard.

Please check your site now.

This is absolutely fabulous - thank you so much for your help. Not knowing what to look for, I don’t think I would have managed to locate that issue within the file structure.

The site appears to be working exactly as expected again. I am not sure how the recent updates could have caused this to happen but will keep an eye on it in the future.

Thanks again.

You’re welcome but please note that those rules aren’t added by our products. Our products will never add such configuration as they are not related to any functionality in our products. If not by your web host, it could have been added by a third party plugin especially security plugins.

What Ruenel did here is beyond the scope of our support. We do not usually investigate issues that are not caused by our products.

With that said, it would be best that you learn what setup you add in or use in your site so you can diagnose issues on your own.

Thank you for understanding.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.