Just purchased renewal and downloaded. License Expired

Confused. Just downloaded and it says link expired. Please send a new one

Hi there,

Our apologies but where are you getting the link from? Kindly provide us more information so that we can provide further suggestions.

Thank you.

From the logged in downloads page

C:\Users\Paul Wagner\Downloads\themeforest-5871901-x-the-theme.zip

Hi @avwebmaster,

This usually happens when the upload_max_filesize value of your PHP settings is less than the size of the file you are uploading.

If you have an access to the php.ini file of your hosting, try adding these code in the file:

upload_max_filesize = 64M
post_max_size = 64M
max_execution_time = 300

You can also check http://www.wpbeginner.com/wp-tutorials/how-to-increase-the-maximum-file-upload-size-in-wordpress/

Or you may also get in touch with your hosting company and have then double check the following values above.

Another option would be to upload the theme manually through FTP. Go to wp-content/themes then upload the unzip x folder in there. Then navigate to the wp-admin dashboard and you should see X installed.

Hope this helps,

Then why does the message say “expired link”?


It’s a wordpress error message and a known issue if you have low upload max.file size limit

Please check linhk below



Installing Theme from uploaded file: themeforest-5871901-x-the-theme.zip

Unpacking the package…

Installing the theme…

The package could not be installed. The theme is missing the style.css stylesheet.

Theme installation failed.

Notice: Undefined index: download_url in /home/avwebmasterdev/public_html/wp-content/themes/x/framework/functions/global/admin/addons/class-theme-updater.php on line 57

Notice: Undefined index: latest_version in /home/avwebmasterdev/public_html/wp-content/themes/x/framework/functions/global/admin/addons/class-theme-updater.php on line 57

Notice: Undefined index: download_url in /home/avwebmasterdev/public_html/wp-content/themes/x/framework/functions/global/admin/addons/class-theme-updater.php on line 59

Notice: Undefined index: latest_version in /home/avwebmasterdev/public_html/wp-content/themes/x/framework/functions/global/admin/addons/class-theme-updater.php on line 62

Ok tried doing it again and it seemed to work but still looks like code. http://avwebmaster.com/ Do also need to purchase wpbakery? How do I fix this mess?

Hi there,

You do not have to purchase the WP Bakery plugin as it is on for the bundled plugins with X. Kindly make sure that you have the latest version of X installed on your site and you have validate your theme installation so that you will be able to install the bundled plugins of your choice.

You may download the latest version of X from your dashboard.

Here are some more information on how to validate X:

Once X is validated, you should be able to see the plugins list in the X page of the admin area:

Once WPBakery is installed and activated, please go to WPBakery Page Builder > General Settings and make sure to enable Legacy X Integration.

Hope this helps.

Well, it would be great if I saw these settings but X in the dashboard ignores my clicks even with the current updates version, https://www.screencast.com/t/9eDwN12k0mY Other thoughts?

Ok If I recently repurchased the license, why does it not show up, edited, here?

I purchased the renewal for my $30.88.

This is what you sent me, but there was no order number

X | The Theme
Support now valid until 18 Jul 2019

Also, I am noticing that support keeps getting slower and slower.

Hi There,

Upon checking your website, I could see that you didn’t install the Cornerstone plugin yet.

Please re-visit the validation page and it will install the Cornerstone plugin automatically.

If you’ve validated your website already, you should be able to install the Visual Composer plugin.

Would you mind providing us with login credentials(by clicking on the Secure Note button at the bottom) so we can take a closer look? To do this, you can make a post with the following info:

  • Link login to your site
  • WordPress Admin username / password


Ahem, I don’t see a Secure button which I would share with you if I could my login info. and as I explained, the Validity and Cornerstone blocks are not showing.

Hi @avwebmaster,

It should be under your existing reply,

And as recommended above, you should install cornerstone first by going to Admin > X > Validation, just wait a bit and top message will appear once it’s installed. Cornerstone is also needed for WPBakery’s X integration to work.

And have you renewed the support from Themeforest? If yes, it will only renew the support coverage as Themeforest implement but it will not give you a new license/purchase key. Your purchase key will be just the same as registered before. Your existing license is good and working and the current issues you’re currently getting aren’t related to it.


Hi There,

There might be the error with the permission of the files:

All the style & script files under theme directory are returning 404 errors.

Could you please contact to your hosting provider to correct the permission of wp-content folder?

For more information, please take a look at this: https://codex.wordpress.org/Changing_File_Permissions

Hope it helps :slight_smile:

Finally, someone who knows whats happening. That fixed most of it Thai. And now I see the X dropdowns. When I click on Cornerstone and the home page, it’s still showing code. How do i fix that?

Hi There,

I was able to install Visual Composer Builder plugin:

Your home page looks good now.

Please correct all the image links.


Thank you, thank you, Thai!

Yes, I need to fix the images.