Javascript editor

I just had X-pro auto update on one of my client’s sites. Here we go again, like starting over to learn where to find everything again. What happened to “If it ain’t broke, don’t fix it”? I was perfectly happy the way it was, but it is what it is, I suppose.

My real question is in regard to the Javascript Editor window. It used to be when you highlighted a punctuation mark in the code, it auto-highlighted the associated punctuation. It no longer seems to do that, which makes it much harder to troubleshoot code.

I’m trying to learn JavaScript and one issue I keep having is getting the punctuation right to be sure to close a script. If I’m missing something, it simply alerts me that it’s missing, but it is much harder to figure out now that the highlighting feature is gone.

Hi There,

Thanks for writing in! After doing the updates, always make sure to clear all the caches including the ones in your browser. You can also use private browsing mode to make sure that you are viewing the latest codes from the updates and not the cache version. If the issue of the Javascript editor occurs, it could also be caused by a plugin. Please make sure to update the WordPress core and all the plugins as well.

By the way, please provide us a video screen cast or at least the steps on how we can replicate the issue so that we can investigate it further.

Cheers.

Thanks Ruenel. In looking at this very closely, the editor is highlighting correctly. The issue really is, in the new release, the text in the admin panels has gotten really small. I’m having a hard time seeing it. Also, the yellow background color in the custom code window is a bad choice, as there isn’t enough contrast between the background and the code. Is there anything I can do to enlarge the text?

Hello,

Try the following in your UI CSS. Find it in the dev tools after enabling in the preferences. Good luck on your javascript adventure.

.CodeMirror {
  font-size: 20px !important;
}

Hello. I activated Dev Tools and added the CSS. It had noooo effect.

Hey @mcaravaglia,

I did follow what my colleague said and it was working properly on my end.

Please make sure that you add !important in the font size.

Hope that helps.