Issues with cornerstone, revolution slider & M.E. Calendar after the new update

I updated to the newest version of wordpress and updated all my plugins (besides the ones that need an activation key) Those I have deactivated. Cornerstone editor is very slow and some of the elements don’t work as they used to, like the feature list. The icons aren’t right beside the text anymore. They’re awkwardly sitting on top. It was nice before when I had a list of 1-4 and the text lined up with the number graphic. Cornerstone seems very finicky and it freezes on me as well.

I’m also having issues with Revolution Slider and M.E. Calendar. The shortcodes don’t work in cornerstone for the events calendar and I have feature images for the posts. Nothing shows up. Revolution Slider doesn’t show my video on the live site but oddly displays when editing cornerstone, but it doesn’t fit the whole area. I have a video I want to display above the masthead and the plugin doesn’t seem to be working. I have already tried deleting it and reinstalling. I really want these to work :confused:

Hope you can help. I appreciate it! Thank you.

UPDATE: I had forgotten to update X theme. The feature list works now and cornerstone seems to be working smoothly.

I’m still having issues with Revolution Slider and M.E. Calendar. There is an error when I try to update the Modern Events Calendar. Says: “An unexpected error occurred. Something may be wrong with or this server’s configuration. If you continue to have problems, please try the support forums.” It showed up to update the plugin once I updated the X theme, but still an error.

Revolution Slider has not worked for me at all. I have it set up to play above the masthead but it doesn’t show up. I have the slides all set up and even tried importing a slider template and nothing shows. It’s just blank where the slider should be playing. I see it in cornerstone when I’m editing so I don’t know what’s going on. It doesn’t show up live.

Hi There,

Please clean the cache of any cache plugins.

Please try testing for plugin conflicting by turning off all third party plugins.

If that does not help please provide your login credentials in a secure note.

Thank you

Thank you but I don’t have any caching plugins. I turned off all the plugins and Revolution Slider still doesn’t work. I am working on my local development site so keep in mind that my credentials for my live site doesn’t have all the updates, and yet the Slider still doesn’t work. It currently has an optional video playing above the masthead but playing a slider does not work. Modern Events is not on my live site but since it doesn’t work on my local, it won’t work on the live either.

Hello Again,

Thanks for updating in! Please understand that with bundled plugins such as Rev Slider and ME calendar plugin, we are the one who will provide the updates. In your plugins section, it may notify you for the newer versions but still you won’t be able to update it because you will be connecting to our plugin repository. Please also make sure that you have validated X theme so that you can connect to the plugin repository.

If you haven’t validated X yet, please do because you will receive an error connecting to the plugin server if X is not yet validated. ​To validate X properly, please do the following:
1] Please login to your account and assign the license ( You need to assign the license to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
2] Go back to X > Overview again, and insert the license again.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

By the way, you can check out the latest supported plugins from this article:

Hope this helps.

I have my local site validated so that isn’t the problem. I’ll switch it back when the development site has all the changes made. Did anyone login to my site? The plugins don’t work though with or without the updates.

Hi There,

Each license allows you to validate your website in development and live sites.

Please go to your Apex License page and assign your URL and validate your website.

After that please update Wordrpess, X , Cornerstone and the bundled plugins to the latest versions.

Let us know how it goes.

Thank you

Ok, both sites are validated now. I updated to wordpress 4.9. Cornerstone and X are already the latest versions, along with all my other plugins.

The Revolution Slider still doesn’t work neither does MEC. Also my header isn’t responsive anymore as a fixed header. You scroll past it.

Everything is updated on my development site. I will migrate all the changes to the live once the troubleshooting is complete but having many issues with these plugins.

Thank you for your help.

Hi there,

Your live site is still in old versions which I understand that you’re working on the staging. But how do access and test your staging? Is it possible to migrate it online, at least as a sub-domain of your live site? It’s the only way we can further check the issues.

Plus, with your live site, Revslider is displaying from my end. So we must really check your staging.


I’m not sure how to create a subdomain. The only way I understood migrating was with the All-in-One Migration. Otherwise I can’t migrate manually. Can I still use that plugin for a subdomain? If I use CPanel, I just create the subdomain through that?

Hi there,

Yes, create a sub-domain in your CPANEL, then install Wordpress to your sub-domain (in CPANEL too).

Then login to your sub-domain’s Wordpress admin and install All in one migration plugin.

Then yes, export and import your site using All in one migration plugin, the destination should be your sub-domain’s Wordpress.


I am still in the process of creating a subdomain. It should be instant but even the index isn’t showing up when I create a subdomain through cpanel.

I can access cpanel through ehost but I can’t login to the cpanel customer portal to enter a support ticket. I contacted Gandi SAS (my domain registrar) to update my domain nameservers. Needs to be pointed to the IP address. So waiting on that.

I’m a newbie with all of this, I apologize. I will get it up and running as soon as I can.


Please contact your hosting provider on this particular issue as it sounds like something related to your setup is causing this. Typically, this is due server configuration problems (i.e. underpowered, traceroute issues, packet loss, permissions errors, et cetera). Additionally, your host will be able to diagnose things much better due to the fact that they have a more complete view of your account and can work behind the scenes with you. If the problem you are experiencing persists after working with your host, don’t hesitate to let us know and we will be happy to assist you. Any relevant information that you can share with us from your host is also greatly appreciated as it will help us to better ascertain the source of the problem.


Well my host is ehost and they told me they can’t help me since my nameservers aren’t with them. It will have to be through my domain registrar.

Thank you so much for helping!

Hi There,

It seems you did not update the staging site’s wp-config.php file or maybe you forgot to upload the database?


Editing wp-config.php file

After you have successfully accessed your staging site, please update everything. WordPress, X Theme, Cornerstone, and Plugins (refer here for the latest compatible versions).

Updating WordPress
Updating Your Themes and Plugins

Remember to clear all caches (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Let us know how it goes,

I got it all set. After the migration though my images aren’t showing up. All the same images are in the media library so I’m not sure why. I already tried UPDATE wp_posts SET post_content=(REPLACE (post_content, ‘’,’’)); with my site names and it didn’t change anything. Do I have to update every image again? It’s blank in each element. It seems like all the links are correct. I updated permalinks twice…

I used all-in-one migration

Hi there,

How did you migrate it? The All in one migration plugin should do all of that, including the replacement of URLs. Could you try it again with that migration tool replacing existing content in your staging?

We can only move forward once you fixed this first set of issues.


I did the migration over again. It’s up and running now! Thank you for being patient :slight_smile:

Hi There,

You’re always welcome!

I then checked and found the following JS error:

Unfortunately. there is a known conflict with MEC plugin. The developer are aware of the issue though there’s no update yet. See this thread: We’re sorry for the inconvenience and the time it took you find that this is a known issue. Thank you for understanding.

Okay, I will forget about MEC for now. I still have issues with the revolution slider. I have it deactivated right now but I couldn’t get any of the free templates or any slider I made to show up.

The header is fixed to the top and it doesn’t seem to be working anymore.

Also, you can see I have a slideshow with arrows to view photos and it’s not responsive there at all (under Sell. More. Food). It shows the red box underneath. I can’t seem to get that section nice and neat. I’ve tried the revolution slider instead of just the element slider and it disappears. Any other suggestions?

Thank you!