Issue with essential grid and cornerstone not working properly

It looks like I’m having some kind of caching issue, but I have tried disabling all of my caching tools and nothing is working. Here are the two things happening

  1. Cornerstone is not working. It says The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.

Origin URL:

Preview URL:

  1. Essential grid is not working properly. There’s one on (under A Dietitian’s Kitchen) that should have a semi-transparent cover that rolls over when you hover.

Update: i identified a plugin conflict for the cornerstone issue. Essential grid is still not working

2nd update: now Cornerstone is not working again. So I don’t know what’s going on.

Hi there,

Please kindly follow the troubleshooting steps below and get back to us with the results:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.
  8. Check the workarounds in this article:

Thank you.

Hi, I have tried the above and seem to have identified the cornerstone problem as a plugin conflict. However, I cannot figure out the problem with essential grid. The problem persists with all of the above done.

Hello There,

I have logged in and checked your site. It seems that there is a JS error in your Essential Grid in the WordPress admin area.

Please re install Essential grid plugin. There might be corrupted files which may have caused this issue. Please do not delete the plugin in your WordPress > Plugins section because it will wipe out your grid as well. You will need to login to your ftp, browse to the plugins folder wp-content/plugins/ and delete the essential grid folder. You can then go back to WordPress > X > Overview > Extensions and re install the plugin.

Please let us know how it goes.

Thanks, I have done that now but it seems the problem persists

Hello There,

I have logged in and check your grid. The preview and the final display of the grid in the home page is exactly the same. It does not have a semi-transparent cover that rolls over when you hover.

Please check your skin or may need to edit the skin. To edit the skin, please check this out:

Please let us know how it goes.

Hi, is there some update that would have changed or broken the functionality of this skin? It has indeed had a blue semi-transparent cover that rolls over, which has worked fine for months now. I haven’t made any changes or edits to the skin so I don’t know why it would have stopped working now. I did see that the preview looked that way as well, but I just figured that whatever was messing with the front end was probably messing with the back end as well.

Hello There,

This could be because of your server cache. Since you are using SiteGround, could you please clear your site cache or disable the supercacher in your hosting panel? The SuperCacher is developed by SiteGround exclusively for their customers. It increases the number of hits a site can handle and boosts the website loading speed. The SuperCacher includes 4 different caching options for maximum optimization of your websites. You can access the tool by clicking on the SuperCacher icon in your cPanel.

For more information about this, please check it out here:

Hope this helps.

Hi thanks. I had already tried that, but I tried again, disabled all levels of supercacher and flushed the cache. I also flushed cloudflare at the same time. The problem is still there


In that case, please provide us your wordpress login again.

The one provided above doesn’t seem to work.


Can you try again? I just tested that login and it worked for me.

Hi there,

I tried some cleaners too to make sure there is no internal and no luck. It’s the same with clean content too. The last thing that I can’t check is your CF’s setting. Would you mind providing your CloudFlare’s login credentials as well?


ok here it is

Hello There,

We have tried to logged in to your CloudFlare account and we are asked for an Authentication token.

Could you please disable this so that we can check your CloudFlare settings. Meanwhile, please make sure that you are using the recommended CloudFlare settings which you can find it here:

Please let us know how it goes.

From what I can tell, I have no way of turning that feature off. It seems like an automatic cloudflare security feature.


It seems to be generating a new token each time. We can’t login.

You can add the code below in your Theme options > CSS to get similar hover effect in your essential grid.

#recipes .esg-entry-cover {
    background: rgba(0, 150, 140, 0.65);

Hope that helps.

Thanks, that’s close. It doesn’t roll around the grid like it should. Is there an email I could setup with an automatic forward so that you immediately get the email with the authorization token from cloudflare?

Hi there,

How should it roll? About the CF, even if you can provide authentication token automatically there is a chance that it would regenerate new one since we’re from a different part of the world, plus, our IP is dynamic and may change anytime.

And I think, you can turn that off. There are similar issues in the forum that requires CF login and we don’t get any authentication.