Issue with "App" Expanded Demo


Having an issue with the Expanded Demo, posting a new thread as requested from this thread:

I’m the user “@danielkjennings” assisting clients - was looking to try and utilize this theme when I ran into this issue:

Installed the demo but the home page is just completely non functional. It doesn’t even display the WP black menu bar up top.

Other pages appear to be functioning fine.

I’ve tried search the forum for this but everything that has “app” in it will only results in “appearance”

Not sure if there is a plugin I need to install and activate or not?

When I tried to edit the home page with cornerstone, I get the following pop up error in red in the upper right corner stating: “Uh oh!
An unidentifiable error is preventing the live preview from loading. Switching to Skeleton Mode.”

Additionally, is there a specific part of the forum that addresses each of the expanded demo’s needed plugins to function as they appear on the demo pages?

Thank you

Hello There,

Thanks for the very detailed post information. Always keep in mind that before your import any of the extended demo content, you must install the necessary plugin. For example, if the demo has a slider, you must install and activate Slider Revolution first before importing the demo. You won’t be able to install any plugin if you haven’t validated X theme yet.

To know more about demo contents, please check it here:

​To validate X properly, please do the following:
1] Please login to your account ( and assign the license. You need to assign the license to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
2] Go back to X > Overview again, and insert the license again.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

I am having this exact same problem, as posted a few minutes ago. Exactly the same problem, with the same Cornerstone error. Daniel, did you get this sorted? What was the issue?

Hi @warrenfab,

Thanks for writing around! Please follow @RueNel’s suggestion first and let us know if this resolves your issue.