Issue ProEditor vs LearnDash plugin

Hello,

I brought this issue in January, the ticket was interrupted/stoped because we were debugging the issue on the online website so I needed a staging environment for you to inspect.

The issue is when I try to edit, with Proeditor, the Lessons from a course (LearnDash plugin) I get the preloader looping forever. Whats funny is that this issue only happens when I try to edit a lesson page from LearnDash using proEditor.

Please dont answer this ticket with “I would like to suggest troubleshoot the following common issue to help us to recognize the reason” (dont get me wrong, i love you but I already test everything and the issue persists)

The online website still not update because of this issue. The version installed on the online website is 4.0.11, if I update I face the problem I just described. Please check the steps on the private note, and I am looking forward for feedback anxiously.

Hello @juliana,

Thank you for the very detailed post information. I have checked your site and there is a JS error on the site which is why the builder is not loading. This is because you have added an incorrect JS code in Pro > Theme Options > JS section. Be advised that the provided JS section in the Theme Option can only accept JS code. It will result to an issue if you insert HTML tags like <script> or <div> tags. You have inserted this code which created the JS error:

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/pt_PT/sdk.js#xfbml=1&version=v2.12&appId=194614867796159&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- MailerLite Universal -->
<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '2113190', 'f8j0o0u3n7', 'load');
</script>
<!-- End MailerLite Universal -->


<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/pt_PT/sdk.js#xfbml=1&version=v8.0&appId=194614867796159&autoLogAppEvents=1" nonce="DmDNL2Dx"></script>

<script src="https://apis.google.com/js/platform.js"></script>

Please remove this code. You will have to install “Insert Headers and Footers” plugin instead. The plugin will give you a way to integrate your JS code into your site seamlessly.

Best Regards.

Hello @ruenel

Did you try remove the code and see if the issue persist?
Because I removed the code but the problem stills there maybe you tried on a page from a course and not from a lesson. Go to the private note and click/test on the link I shared on step 2.

Note: Like I said, on the version 4.0.11 this problem doesnt exist, thats why on my online website I didnt update the theme yet

Hey @juliana,

Thank you for confirming you did the troubleshooting steps already. That’s all we need before we investigate.

It looks like the LearnDash scripts needed for the functionality of the lesson interface are in conflict with the latest version of Pro. I’ll post this in our issue tracker so this case will be queued to be investigated by the development team.

Please keep the staging site up and credentials the same.

Thanks.

hello @christian
I will wait for your response but please dont take too long to give feedback about this issue because I need to make updates.

Hi @juliana,

My colleague has already reported the issue for further investigation, and you will be notified once it is updated.

Thanks

Hi @juliana,

I’ve taken a closer look at this and unfortunately I don’t have good news on the situation. When the builder tries to load, a request is made for the live preview but it never completes. After a while it crashes with a 503 “service unavailable error”. This might mean there’s an infinite loop happening, or perhaps the system tries to access a resource that doesn’t respond.

Another things I noticed is If that page was previously built with Pro (or Cornerstone) we should at least see the generated shortcode output in the WordPress text editor. With it being gone, it could mean that content was deleted or corrupted.

While it is possible to enable the Pro Content Builder for any post type, this is generally meant for custom post types that are standard forms of content. We don’t integrate with LearnDash, nor can we guarantee compatibility with third party plugins. When updates take place (plugins, themes, WordPress core, etc.) there is always a chance that a change in one system will affect another. We will work to resolve any issues to ensure full compatibility with WordPress and any of our supported plugins. We’ll on occasion try to investigate issues with other plugins as part of support in case there’s a solution we can uncover. Regretfully at this point, I don’t see any clear options to make this work again from our end.

Hi @alexander,
oh no…
When I create the staging website, before the migration I tested if the plugin and the theme worked together both updated in the last version… and they work, I mean I can open lessons using proeditor. I just dont understand why suddenly this happens.

I have to think what to do now… but if there is nothing else you can do, I cant continue on themeco, unfortunately. Its overwhelming all the learning curve to be a ProNinja and now falls apart.

Thank you

Hi @juliana,

It will very difficult to say what exactly happened at your end, I can suggest you try restoring the backup version to the staging once again and repeat the steps you have done and check where it exactly breaks. If you find anything during this investigation, you can let us know.

Thanks for understanding.

@tristup seriously…

its working fine on the theme version 4.0.11 already said at least 2 times here. So any version after 4.0.11 doesnt work… so How it can be “at my end”?

" I can suggest you try restoring the backup version to the staging once again and repeat the steps you have done and check where it exactly breaks." — again the issue reveals after I update the theme

Hi Jujiz,

As Alexander said, there’s no clear option to make this work again from our end. You can stay with Pro 4.0.11 if you still want the integration works on your website or you may seek 3rd party developers to help you with your problems.

Thank you for understanding.