In default search modal of cornerstone i want to remove extra erase icon?

as you can see in the picture that their are two erase icons so i want to remove the blue one , from where i can remove this icon?

hello anybody is here to solve the issue?

Hey Ketan,

Thanks for writing in!

In the default Search Modal, there is only 1 erase icon.

You must have used a custom CSS or there is a 3rd party plugin that is causing this issue on your site. We would love to check this out. You can create a secure note in your next reply with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
– Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works


Best Regards.

i added the details in secure note.

Hi Ketan,

There might be some different reasons behind your problem, I would like to suggest troubleshooting the following common issue to help us to recognize the reason.

1.Theme Related Issue
2.Plugin Conflict
3.Theme Update related issue
4.Child Theme Related issue
5.CSS/JS Customization
6.Disabling Cache
7.Disabling CDN

If you discover that an issue is coming from a custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.
If that does not help, please copy your live site to a staging server so we can troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


you can also troubleshoot on staging site.

Hi Ketan,

I have checked your staging site and deactivated and activated all the plugins but didn’t find the issue you described here. Please compare the plugin list in your live and staging site, seems any of the plugins is having the problem.

Hope it helps.

both the sites having same plugins.

Hi Ketan,

In that case, please check if everything is working on the staging site and you can migrate the staging server to live and try to activate the license once again.
Please note that you should take a backup before performing it. So if anything goes wrong, you can restore it.


I can’t do this thing. Please suggest me some feasible solution for this. As I tried with plugins enable disable too. But that X symbol comes when the input element is set to focus or when a user tries to type in. I tried to inspect via enabling the hover state too but none helped me. Please help me to solve this as soon as possible.

Hey Ketan,

It seems that it happens on the other staging site. Add this custom CSS from this article:

.clearable input::-ms-clear {  /* Remove IE default X */
  display: none;

Kindly let us know how it goes.

No It didn’t helped me.

is anyone is their to help me out/?

Hi Ketan,

Please add the following custom CSS code to remove the default cross button.

/* clears the ‘X’ from Internet Explorer */
input[type=search]::-ms-clear { display: none; width : 0; height: 0; }
input[type=search]::-ms-reveal { display: none; width : 0; height: 0; }
/* clears the ‘X’ from Chrome */
input[type="search"]::-webkit-search-results-decoration { display: none; }

Hope it helps.

Hey, It worked.
Many Thanks To You!

Hi Ketan,

Glad that we are able to help you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.