iFrame response cant build a page unless its live

We have a subdomain we’re making landing pages on but ever time I try to create a new page using X Theme, it says I have an iframe issue related to PHP settings. I can’t build a page unless I publish it live, which is of course a problem. Can you please let us know a fix? I have disabled all plugins to try and find a workaround and nothing works.

Hey Kris,

Thanks for reaching out!

There could be a plugin or custom code that affects your website.

I recommend the following troubleshooting procedures before we investigate the settings.

  1. TESTING FOR THEME RELATED ISSUE
  2. TESTING FOR PLUGIN CONFLICT
  3. THEME UPDATE
  4. CHILD THEME
  5. CSS/JS CUSTOMIZATION
  6. VERSION COMPATIBILITY

Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hello. I had my web dev do all of these steps and he was still not able to resolve this issue. Can you please have your team take a look? Secure login below.

Hello Kris,

Thanks for sharing the login details it seems that it is working fine at the end. It might be the issue of the browser cache I would suggest you please clear your browser cache and then check it again.

Thanks

Hello. It is not fixed, this issue is still present (see screenshot)

  • The steps I took were:
  • Create new page and give it a title
  • Backout to main WP pages section
  • Click “edit with cornerstone” from the pages section
  • And I get the iframe error.

Hello Kris,

I followed the steps that you have mentioned and it seems that the page builder is working fine at my end. Please have a look at the video in the secure note. I have used Google Chrome Version 102.0.5005.115. Please let us know your browser and its version.

Thanks

Yes, you’re publishing the page, then working on it. We don’t want the page live while we are working on it. Want to have it as a draft, build the page, then publish it live.

Hello Kris,

I could not replicate the issue on my end as well. Check out this demo video:

I have a hunch the the issue is only occurring in your WP installation. Perhaps a 3rd party plugin is causing it. Kindly temporarily deactivate your LiteSpeed Cache and the Redirection plugin and then you edit one of those draft pages.

Kindly let us know how it goes.

Hi Ruenel,

This is not the case. I turned off all of our plugins and still had the same issue (that was literally in my first post I made).

Can you please try and get this resolved ASAP? We’re nearing the end of the week here and I simply can’t go another week with this issue.

What you just showed me above on the video, does not work for me. I cannot edit a draft in cornerstone. I also see in your video you are not on our site, which makes me question the support were receiving here. We purchased three of these themes for different domains we have, I need this theme to be solid. Please take another look.

Hello Kris,

I went ahead and checked your settings and I replicated the issue. I checked your draft page and it seems that the page builder is not working on this page. Please note Cornerstone uses WordPress Rest API. The Rest API requires Permalink as Post Name. Now if you check your draft page there is no page slug which means WordPress has only assigned the page ID but it has not got the unique page slug. Please note if there is only page ID it means Permalink is in the Plain mode just because WordPress Rest API is not working and if the Rest API is not working then Cornerstone page builder would not work properly without Rest API. I would suggest you just need to add the page slug so that the Cornerstone page builder works properly.

Thanks

YES! Awesome, this is most likely the fix. Ill give this a try, thank you!

You are most welcome Kris.

Hello. Just tried this, still not working :frowning:

Please look at this page, it has a permalink but when I edit it in cornerstone its looking for the page_id. What am I doing wrong here?

Hello Kris,

I checked your page it seems that there is no page slug saved.

I checked in the edit page made as well please note if you click on the View page URL [Right-hand side under Permalink] it would take you to that URL with Page ID, It would not take you with the correct page slug. To avoid it you need to publish the page first then you can change it to Draft mode. After changing it in the draft mode you can check it again.

Thanks

Ok. I did as you suggested.

Created a new page
Published the page
Went into cornerstone and went to the gear icon, switched to draft
Went back to dashboard
Go to pages
Click “Edit with cornerstone”
Get the iframe error

What’s next? Have you looked in the site again?

Hi Kris,

I have checked the same in my local environment and Page Builder loads the draft pages perfectly. It might be something else is the reason behind your issue, as you have already performed the common issue troubleshooting and still having the issue, I would suggest you please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access to the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.

Thanks