Header Snaps on Scroll

My header seems to snap when I scroll. I have the header set to relative so it will not overlap the content. I can’t seem to figure out why it is resizing. The website for an example is as follows: https://largeladders.com/

Hi @jearredo,

Thank you for reaching out to us. This usually happens when Trigger Offset is set to 0, try increasing the Trigger Offset value and see if this resolves the issue.


If the issue persists then please get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.


It did not work. It created an undesired effect. I can get close to what I want. I would change the sticky header to relative. The problem then becomes it creates an overlap over the content. I have inserted the sign in info into Secure Note and temporarily removed the 2-factor authentication.

Hi Jearredo,

To resolve that please do the following, duplicate the Bar 2 and turn Off its Sticky Bar option. Let the duplicate bar be the Sticky Bar.

On the Duplicate Bar keep the Sticky Bar On, turn On the Initially Hidden option and set the Trigger Offset to 124 (124 is the total height of your Masthead/Header adjust this accordingly)

This way you’ll get a smooth transition between the static and sticky header and flexibility to configure the sticky header differently.

Hope it helps,

Won’t that cause me to load the content in the header twice? I don’t want to increase the size of every page through this workaround. I changed it back to how I originally had it. If there is a way to work with this, great. If not, I will figure it out on my own.

I have been having a lot of problems with your software lately. It keeps freezing. If I zoom in on my computer while editing, and then zoom out, your theme crashes and I have to do a hard refresh losing all my changes.

Many times your editor does not implement the text changes in real time. I have to double click inside to see the change, refresh, and then it will appear.

Additionally, I am not sure why you have items in design cloud that cause your entire site to change. I downloaded a afew of your templates and had to go back to a previous saved version of my theme because the templates changed other features on my site. Please get this fixed; this is not a good user experience.

Hey @jearredo,

I checked your setup and it seems like you’ve fixed the snapping problem by changing the initial position to Absolute, however there was a jerk effect while scrolling back to the top so I went ahead and changed the Shrink Amount to 1 (see screenshot)


Now the transition is very smooth in both ways either scrolling up or down.

Zooming should not cause any issue with either content builder or header/footer builder. I just tested it in your header builder and i got no crash. It’s more likely to be an issue with your browser or system. You can try this in another browser and see if it does again.

When you install any site It is important to note that while the import of a Site asset will not overwrite or alter any of your posts, pages, or portfolio items, your Theme Options will be altered. This is necessary so that we can setup your installation similar to the demo of your choice. If you already have your website setup but are still curious to try out a new Sites demo, please make sure that you first backup your Theme Options by going to the X / Pro > Validation menu within Theme Options and clicking Export :

To learn more about Design Cloud please see https://theme.co/docs/design-cloud#how-to-install-an-asset

Hope this helps!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.