Header Assignments

Hello! I recently created a new header with a Mega Menu - and now I cannot see any of it to edit it in the Header Builder. I see the elements in the container/bar, and I see the child elements within the menu…but it simply doesn’t show up for me to see it or make any changes.

I’m also unable to assign it. When I tried to apply it to the entire site, it just kept the previous header - perhaps it’s a priority issue?

Help or guidance would be greatly appreciated. Thanks.

Hi Lysa,

Thanks for reaching out!

For more information about the header assignment and priority. Please check this out:

On the other hand, If you can’t figure it out. Would you mind sharing your admin credential so that we can check your header settings? To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Added a secure note with credentials. The link is helpful but I can’t even see the header so that’s the first problem. It’s called Mega Menu Test (when you look at my headers).

Hello Lysa,

The MegaMenu is not displaying because you have added a condition in the Megamenu > Customize > Conditions. I have removed the conditions already.

Screen Shot 2021-06-10 at 7.57.07 AM

Check your header now.

I still can’t see it or edit it. Gives me an error “The preview cannot load due to to misconfigured URLs”

Hello Lysa,

It seems that you have not assigned the header and not set any preview page as well just because you are not able to preview it in the backend. Please have a look at the screenshot in the secure note to learn more about how to set the preview.


That worked, thank you! Finally seems to be working and editable. One last question: How can I make it appear on Hover rather than click?

Hello Lysa,

The Megamenu is using the modal element which needs to be toggled. If you want the submenu to appear upon hover, please go to Megamenu > Customize > Toggle Custom Attributes and insert “data-x-toggle-hover” with a value of 1.
Screen Shot 2021-06-11 at 8.44.31 AM

Kindly let us know how it goes.

Fantastic help as always! Thank you. Everything is in working order.

Hi Lysa,

Glad that we are able to help you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.