Global blocks preview could not load due to the iframe response being incomplete - HELP

Hi,

I am having problems editing global blocks and creating new ones in https://mensandbeauty.com.

Note: It only happens in global blocks. Posts and pages work perfectly.

Editing a global block

Creating a new global block

I had try to:

  • Deactivate all the plugins
  • Upload theme files again

And I still have the same problem.

Could you help me?

Hello Ignacio,

Thanks for reaching out. Could you please update to the latest versions?
Our latest versions are:

  • Pro theme 4.2.3
  • WordPress 5.7
  • PHP 7.4

This latest release contains fixes for several issues so be sure to check out the changelog:

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And lastly, go to Settings > Permalink and update your permalink settings. Test your site by editing the Global Block again.

Please let us know how it goes.

I already have the latest versions.

Hello Ignacio,

Thanks for sharing the credentials of the site. I went ahead and checked the plugin conflict. It seems that there is some plugin conflict on your server with the “Rank Math SEO” and “Rank Math SEO PRO” plugin.

After deactivation these plugins “Rank Math SEO” and “Rank Math SEO PRO” your global blocks works fine at my end I would suggest you check by deactivating these plugins.

Please note that we don’t provide any third-party plugin support. It is out of the support scope. You may contact the plugin developer who can assists you with your concern or fix their plugin issue or make it compatible with the X/Pro theme.

Thanks for understanding

Ok thanks, I´ll contact Rank Math support to see if they can help me.

Hi Ignacio,

Great! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

Hi,

I had contact Rank Math dev, and this is what they say:

They are seeing the error even when Rank Math is disabled.

Hi Ignacio,

Thanks for the video! Would you mind sharing again your credential so that we can double check the issue? because the above credential is not working anymore.

Thank you.

There you have.

Hi Ignacio,

Thanks for sharing the credential.
I have checked and found the issue even after deactivating the Rank Math plugin. There might be some different reasons behind your issue, to investigate it further, I would suggest you please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.

Thanks

Hi,

You can access the test site in: https://pre.mensandbeauty.com/wp-admin/

Hello Ignacio,

I have logged in and temporarily disabled several of your plugins. The Global Blocks is now loading into the builder.

See the secure note.

There seems to be a plugin conflict. You can enable each of the plugins one by one. If the issue will occur again, you’ll know which plugin is causing it.

Best Regards.