Footer is assigned, but won't show up

Hello! I’m at a total loss here - we’ve updated this footer but now it won’t show up. We’ve tried deleting it, saving as a template and creating it anew. It’s assigned globally but won’t appear at the bottom of any pages.

Hello @richardcreative,

Thanks for writing in!

I checked the website and it seems that the parent theme file have been changed. Can you please let us know if there’s any customization made under parent theme files as the default theme footer section is showing blank? I tried to test for plugin conflict but the problem is still there.

Please try out following solutions:

  1. Please reinstall Pro Theme by first activating a different theme then Pro Theme under Appearance > Themes. After that download latest version of Pro Theme from Apex members area and install the same using the instructions mentioned in theme installation guide.

2. I also see that you are using old version of WordPress 5.1.1. Please update to latest version of WordPress 5.2.2 to avoid any conflicts.

Let us know how it goes.


Thanks - we tried updating wordpress yesterday but were not successful. Also weren’t able to reinstall the pro theme this morning. Have reached out to our hosting provider to see what’s up with that. Seems to be a permissions issue of some sort. Thanks for your help!

Hi Danielle,

Yes it’s a good idea to reach out to your hosting provider.

Just to make sure we’re making not overlooking any possible causes, do you confirm that customizations to the code were done on the parent Pro theme?

All our best, Ben

Hey Ben!

So we got our hosting provider to make some updates and we were finally able to update to the latest version of wordpress. We also were able to change to a default theme, re-install pro, then re-activate pro. The footer still doesn’t appear after those steps though :frowning:

We also tried manually installing a fresh copy of pro at the cpanel/file folder level, switching to the old footer setup, then switching back to the new footer builder. The footer did not work in the old setup and it still doesn’t appear on the new footer builder, although it says it was successfully applied globally.

Any other ideas?
We haven’t made any customizations to the parent theme files as far as I know – especially after installing the fresh copy. I know that one is untouched for sure.

Hi @richardcreative,

I tried adding a simple footer that only contains a short text but it also doesn’t show up. For us to investigate further would you mind providing us with ftp credentials in a secure note?

All the best!

Certainly! I’ll paste it into a secure note on this message.

Hi Danielle,

Thank for sharing with us your FTP details. Unfortunately, I haven’t gotten it to work - so I cannot login to it.

BUT… I found the cause of the problem and I have a solution for you. It would require you to tinker with either FTP or your database so if you’re not comfortable working with these stuffs, I suggest you ask for your web host’s assistance.

Before I share the solution, let me quickly tell you about the problem. The cause of the disappearing footer is that the Wordpress Option that our theme uses to assign footers to pages is not working properly. How it got that way - as much as I wanted to have an answer - I don’t know for sure.

But let’s just work on the fact that it’s not working properly. Now the solution is for us to “refresh” that Wordpress Option. Below are two methods to achieve that.

METHOD 1 - Work directly on the database
With this method, you need to access your database using phpMyAdmin. Most (if not all) hosting providers give you access to your database using phpMyAdmin. If you’ve worked on it before, this will come easily to you.

But if you haven’t, do ask for your hosting provider’s assistance on how to access it. Also ask them what database name is using.

Once you’ve access phpMyAdmin and have determined the database name click on the database name and look for the _options table. I think in your case the name of the table is wp_7ysw7zrdxh_options.

Next, do a search for the option name, “cornerstone_footer_assignments” then click the Go button.

You should be able to see something like this:

Next, click the Delete button as shown above. Now, make sure you’re only deleting the Delete button for that record.

Once you’ve done that, header on back to the Wordpress admin and go to Pro > Footers. You should see that the footer you assigned as Global is no longer global.

Please make it global again. Then check the pages on the front-end. They should now have the footer.

**METHOD 2 - Using a child theme** This second method requires you to access the FTP and some knowledge about child themes.

If you haven’t used child themes before, this guide will hold your hand:

Once you’ve setup a child theme and made it the active theme, edit your child theme’s functions.php file using FTP.

Then add the code below:

add_action( 'wp', 'pro_delete_footer_assignment' );
function pro_delete_footer_assignment(){
	update_option( 'cornerstone_footer_assignments', '' );

Then save the changes.

Next, you have to visit any page on the front-end. What this will do is to “refresh” the cornerstone_footer_assignments option.

Now go back to WP Admin > Appearance > Themes and make the parent Pro theme active.

Once you’ve done that, header on back to the Wordpress admin and go to Pro > Footers. You should see that the footer you assigned as Global is no longer global.

Please make it global again. Then check the pages on the front-end. They should now have the footer.

If any of these methods helped, we’d appreciate you tell us about it. :slight_smile:

P.S. One final note if you used METHOD 2. To prevent future unnecessary issues, I would suggest that you either delete the child theme if you don’t need it OR simply delete the block of code you added earlier on the functions.php.

1 Like

Bingo! Option 1 worked like a charm. Thank you SO much for the detailed explanation!

You are most welcome. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.