Essential Grid fatal error on Home page

Hello. I am getting a fatal error on my home page for the Essential Grid plugin. I called my host and we identified it as this plugin after spending 1 hour with one tech and another half an hour with two others at different times of the day. The third tech told me that the Essential Grid plugin isn’t optimized with respect to the amount of RAM that is used. I am on a shared server. I have none of these issues with Envira Gallery.

I am supplying 2 screenshots one of the fatal error message and when I deactivate Essential Grid I get the shortcode on the Home page. Can someone please tell me how to delete this shortcode or do I have to delete the plugin altogether? Plus, not all of my images are showing up in Edit mode. Due to this conflict, I am choosing to use Envira Gallery for my Home page like my other pages where there is no conflict. This is time consuming and a royal pain!

Hello Grace,

Thanks for writing to us.

It seems that it is an issue of server configuration these issues generally happen when your WordPress code requires more memory than the default allocated memory, you get to see this error. By default, WordPress automatically tries to increase the PHP memory limit if it is less than 64MB. However, 64MB is often not high enough.

I would suggest you increase the PHP memory size. In case if you have not seen our doc to increase the PHP memory size please have a look at our doc to learn more about how to increase the PHP memory size.

Hope it helps

Thanks I will try it and report back to you. I will also tell my host what I did if it works so that they can help others.

Hello Grace,

Please let us know how it goes.


None of it worked. I called my host back and they said this:

You’ll want to look into setting up a WordPress memory usage plugin to see where memory is being used on the site. The GRID has a memory limit of 99mb and your site is attempting to use 428.86mb. If you edited your php.ini file to use more than 99mb, you will encounter memory issues as the GRID is not designed to handle high memory usage PHP processes. I was able to locate a plugin that you can use to help determine where memory usage is occurring on your site so you or your web developer can address the issue;

I did download this plugin and installed it but I am not seeing where it is revealing where my website is using the most memory.

Before deactivating Essential Grid, I got the first screenshot image message. After I deactivated Essential Grid, I got the second screenshot message shortcode. Can I just delete this shortcode and the plugin and call it a day? I want to use another plugin that I have less issues with! I didn’t even upload any files having to do with this shortcode. It is empty so I am not sure why it showing up on my Home page.

Thank you.

Hello Grace,

Once the Essential Grid plugin is deactivated, you will only see the [ess_grid alias="clients_grid_2"][/ess_grid] shortcode in plain text. When the plugin is active, it displays a fatal error. Looking at the plugins section, there are several active plugins. Kindly temporarily deactivate most of the plugins and leave the Essential Grid. We need to check whether the error is caused by so many active plugins or just with Essential Grid only.

Kindly let us know how it goes.

Ok. Will do it now.

Ok I deactivated ALL of my plugins and as I suspected it’s Essential Grid but it gave me a different fatal error message. See the screenshot attached and I couldn’t even get into edit mode! I have wasted 2 days on this plugin. If it can’t be fixed, I will use something else. Thanks for your help.

Ok I am activating the plugins now that we know it is Essential Grid. I have to get back to work.

Hey Grace,

I’ll just go back first to what your web host said as it’s incorrect

That is incorrect because all users of the Essential Grid will have the same issue if that is the case.

You previously said increasing the memory didn’t work but you didn’t mention how much memory you increased.

Your web host said:

If that is the case, your web host needs to increase your memory to 512mb or more. If they already have increased the memory, there might be a hard limit set for your hosting plan. Upgrading to a higher plan might solve the issue, please consult with your web host how much memory you can have per plan.

Please note that this limitation in memory is not the fault of the Essential Grid plugin. This is a server or web hosting issue. You can try out other web hosts to test this.


Hi Christian.

  1. Regarding the php.ini file…well I went in and changed it to 512M. The agent I spoke with at my host last night changed the config.php file section that we discussed to:

define( ‘WP_MEMORY_LIMIT’, ‘728M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘900M’ );

/* That’s all, stop editing! Happy blogging. */

I called my host this morning and discussed it with an agent. I mentioned that I have not had a memory issue with another plugin like this and I have 4 other websites in subdirectories under my main domain name. I have not had a problem with any other website and plugins like this out of memory error.

Since I changed the php.ini to 512M and the minimum and maximum memory limit was set on the config.php file to a higher memory number, and all of the other plugins were deactivated, it is still not working! I can’t even get on my Home page to edit it because the circle indicator keeps going round and round and the page in edit mode isn’t showing up. It’s only when I deactivate the plugin that I get the default Essential Grid line of code on the page and can see edit mode in Pro.

  1. The hard limit is 99M from what they tell me. Why hasn’t this happened with other plugins? I see that other people on this forum were getting the fatal error as well with this plugin.

  2. I have been with my host for years and they have always resolved issues for me. It would be way less hassle to change the plugin than to switch hosts. There are not many good ones out there left since some of the good ones got bought out and the customer service is atrocious with some of them. I have dealt with them when dealing with clients who have websites with them.

The dedicated server option with my host is more money so I will try a new plugin first because it would be the most economical choice at this point. If I continue to have issues, then I will look at another plan with either the same host or a different provider. But as it stands, I choose the first option at this time. Thanks for your help.

Hi Grace,

Sorry for the back and forth. Yes, the increasing of memory limit should be the first action done since the fatal error from your screenshot simply says the memory limit is not enough.

Now, since the memory limit has already been increased and the issue still persists, It’s safe to assume that there is another problem within the Essential Grid plugin that is installed on the EagleHeartDynamic site. With this assumption, I would like to do a couple of simple tests (If it is fine with you).

First, is clear all your caching plugins and caching features including server-side caching (if any). Essential Grid has it’s own caching as well, please clear its cache before turning it off (more details about that here).

Now if clearing cache did not work, try reinstalling the Essential Grid plugin, deactivate it first, then delete, then reinstall (details here).

I understand if that would feel a bit hassle to do now, If so, then let’s deactivate and delete the Essential Grid, then edit your home page, the shortcode is either added on a Text element, or Raw Content element, or a Classic Essential Grid element, find any of this element on the section where your grid is placed and delete it. If you cant find the Essential Grid shortcode, please provide us login credentials in a secure note and we are happy to find it and delete it for you.


Thank you for your response friech. Actually, I deactivated the Essential Grid and deleted the shortcode on the edit page. Then I started using Envira Gallery, did some tests and I didn’t get any errors. I will have a look at clearing the cache, deactivating, then deleting the plugin just because I am curious as to whether this will solve the problem or not. It’s the problem solver in me that wants to know. lol

I want to use the Envira Gallery Automatic gallery option but I have a question. If I have different sized images, and I upload them, what is the width I need to model these images with…1200 across? Also, do I just upload them no matter what size they are the Automatic gallery option will resize them to fit the 1200 width for example, or does it have to be exact?

Thanks friech! You guys are awesome. : )

Hi Grace,

The Automatic Gallery Layout will fit your images on a row without cropping so the images will have different widths if you use that layout unless you pre-crop the image in the same size before uploading.

Please watch this short video, this will help you decide which Gallery Layout to use.

Let us know if you find out something about the Essential Grid issue.


I saw this friech but it doesn’t explain anything! For example, what do I put in the image dimensions? When I upload different images, they get cut off and put into squares so I just used the grid layout because after 2 days of frustration with the Essential Grid, I wanted simplicity. lol

For example, if I used a 600 width image and 2 300 width images, that adds up to 1200 but I get an error. I will have to try it again today and get back to you.

Hi Grace,

Great and let us know how it goes.

Thank you.

Hi Marc. Well I am using the automatic option but what I can’t do is include an image that is 300x600 long because I have to define the height so I made it 300px. For example, the eagle in this photo is cut in half so it is not 300x600 but 150x300 because I had to define the height. How do I get the eagle to show up size as which is 300x600 without screwing up the other images? Why do I have to set the image dimensions if they are different sizes? I chose Original Image. But I made the image dimensions 300x300 because I didn’t know what to put down since they are different sizes.

Hi Grace,

Sorry to hear that, but that is how the Automatic layout is, you need a defined height to align the images. If having equal height is not imperative, please use the Mason Layout instead.

Have a nice day,

Ah I see. Thank you friech. But what do I put down as dimensions for the images for the Automatic then? 0? 300? I am using the Original size option.

I may use Automatic compared to the squares on the original home page. The only problem with the Automatic option is that the black border is cut off on all of the images the right side in all of them. How do I fix that? Also, when I move the window in Automatic, the images move to the next row and the size changes affecting the resolution.

Square Options used on the original home page:
No cut off of the border on the right side and the squares stay together as a group when the window is resized.

Automatic Option used on the Home Test Page:
Cut off on the border of all images on the right side and some images resize changing the resolution when the window is resized.


Hi Grace,

Is this Grid ( an Automatic Layout? Can you provide us login credentials on a secure note so we can take a closer look?

The Original image size should be fine.

Have you tried the Mason Layout that I suggested above?


friech I am just communicating with a tech from Envira Gallery. He said there was a conflict with CSS but he took off the border for the images on that page. Not sure why but I asked him to put the border back. It’s interesting that when I click on lazy loading it works but when it’s off, it doesn’t work. I will send you something via secure note.