Essential Grid custom source problem


I’m using essential grid to build some test pages for a new website. I’ve tried to use a “stream” source from a vimeo account. I chose settings, skins etc. and the grid displays and works fine.
Here is a link to that page :

However, I then duplicated that grid and changed the source to “custom grid” , and added some vimeo videos manually. For some strange reason this seems to “break” the grid, because the grid still displays, but it is not functional : when I hover the mouse over the grid items (which are videos) nothing happens, I can’t play the video, it doesn’t show the play button, name or anything.
Here is this page :

I really don’t understand, especially since I kept all settings exactly the same between the 2 pages (apart from the actual media). Could you please help ? Thanks in advance.

Hello Jerome,

Thanks for writing in!

Please make sure that you have inserted the correct ID of the Vimeo video.

To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hello Ruenel,

Thanks for your answer. I am sure I inserted the correct ID of the 4 Vimeo videos, simply because the thumbnails of the videos are displaying. But the grid is not functional : when I hover the mouse over the elements nothing happens (you can see this on this page : ) .

I am ok to send you all the info to access my site, but unfortunately I can’t see the “secure note” button next to the reply button, as shown on the screenshot you sent. Maybe it’s because I’m a new user ??

Right, I’m seeing the secure note button now. It’s not displaying under your reply but it’s displaying under my own reply.

Hey Jerome,

It looks like you will need the Vimeo Player for Custom Vimeo Grid. That’s only available if you have a standalone Essential Grid license though so if you don’t, you need to purchase one and activate the Essential Grid to receive premium skins direct from the Essential Grid author, ThemePunch. Additionally, you’ll get direct support from the author so you can report skin issues to them and they can offer better help.

Hello Christian,

I’m sorry but I don’t understand what this has to do with my problem. I know that if I purchase an essential grid standalone license I will get premium templates and skins, as well as support from Themepunch. But I don’t need those. The “vimeo player” template you mentioned is just a template, which I don’t want to use. And actually, that template is using the “stream” source to load vimeo videos, not custom (see screenshot).

There is no reason why using videos from vimeo shouldn’t work with the copy of Essential Grid I get from buying the X Theme. As a matter of fact, it DOES work, with the “stream” source option, but it doesn’t work properly with a custom grid. This looks more like a bug of some sort, because as I mentioned before, it “kind-of” works because the vimeo videos’ thumbnails are displaying fine.

Thanks in advance for your help.

Hello again. Could you please help me with this issue. Thanks in advance.

Hello Jerome,

What you are trying to do is not possible. Although you are using the same Washington MOD skin for your grid, please understand that the Stream source and the Custom Grid has a different way of getting the source contents for each of the grid items. This is why they do not display the same even if you have the same grid settings excerpt the source of the grid.

Hope this explains your issue briefly.

Hello Ruenel,

I’m not necessarily trying to have the same look between my “stream” grid and my “custom” grid, I’m just trying to get the custom grid to simply work with vimeo content.

Let’s start over with another example. I created an empty (essential) grid to which I added one vimeo video using the custom grid source. I didn’t make any changes to the empty grid, no skin selection or any other setting. The grid displays on the website, because I’m seeing the thumbnail of the video. However the thumbnail is not clickable, the video doesn’t play, the lightbox doesn’t show : it doesn’t work. Here is the test page :
Thanks in advance for your help.

Hi Jerome,

I have created a Test grid with a different Vimeo video and added it into a Test on your website, and it is working fine. But while added the same video you have it creates the problem. I would suggest you check the video once again if that is the reason behind your issue.
Please find the test page link in the secure note.


Hello Tristup,

Thanks for testing it out. This got me onto something, which I thought would resolve the problem : I tried to watch my vimeo video without being logged on to vimeo, it was giving me never seen before message : “Video is not rated. Log in to watch.”. I researched this and found out that vimeo has recently implemented content rating, which might affect playback in some countries :
Unfortunately this didn’t solve the problem ;-( But it’s good to know because it could cause additional problems.

I tried with a few other of my own vimeo videos but no luck. I then added a video randomly found on vimeo … and that works … Honestly I don’t understand !!! I can’t see how my vimeo videos are any different, they are set to"embeddable" and are public, as well as now rated for all audiences, so they should play.

Another strange thing is that when I’m previewing the grid in the editor/preview in essential grid (in the wordpress admin) there I see the play button and I can watch any of my own vimeo videos. But viewing the same grid on the website leads to my videos not playing. This makes me think that the problem could be linked to the X Theme rather than to essential grid.

Finally, even in your test there is something that’s not right : the essential grid skin is not active, the buttons that are there are vimeo’s button, not essential grid’s. Changing any skin settings doesn’t change anything. From what I see in essential grid tutorials this whould not be the case … And it wasn’t the case when I used the “stream” source to load my vimeo videos (see my previous posts).

Hi Jerome,

I’ve update the testvideo1 Ess. Grid to use the Washington MOD skin, and Stream form Vimeo, And it seems to work fine with this Grid (

Can you check the settings of the grid that you’re having the issue, or try to recreate it.


Hello Friech, thank you for your message. Yes, as I mentioned before (in my first message) it works with the stream source option. However it doesn’t work properly with the custom source option. It’s the custom source that I need to use.

Hello Jerome,

In my previous response, I already mentioned that the Stream source and the Custom Grid has a different way of getting the source contents for each of the grid items. Please check out the following settings:

Both the Stream and the Grid source have totally different grid source settings. This is why they do not work the same. The way the data is processed in the background and presented on the front end does not have the same method. You cannot display the Custom Grid Source using the method or design used in the grid with the Stream Source.

Hope this makes sense.

Hello Ruenel,

I am sorry, but this is not being helpful. Here I am no longer duplicating a stream source grid and changing it to a custom source grid, so let’s just not mention stream source grids anymore.

I am here just creating a blank custom source grid, and this blank custom source grid is not displaying correctly. Even in the examples that were created by your team with one of your videos, the grid was not displaying the video correctly, because the essential grid skin wasn’t there.

Thanks for your help

Hi Jerome,

Sorry for the delay, please do the following:

  • Update the Essential Grid to version 3.0.13, to make sure this is not a bug from 3.0.12.
  • Since you choose a custom source on your Grid, you need to input the necessary details for your custom skin to work, e.g. add a Main Image and Title since your skin require this details.
  • Then the play button on your skin, should set to Play Embedded Video instead of Lightbox (

Hope it helps,

Hello Friech,

Yes ! Success ! I’m not entirely sure if it was the plugin update of just changing to the right settings or a combination of both, but it now works !

In case this post can help future users running into this problem, I will give the details of all the settings I changed to finally make my custom vimeo source grid work :

  • I added a title for each video as suggested by Friech (the system doesn’t pass on the original video title from vimeo)

  • I didn’t add a main image as Friech suggested , but what I did instead was set “Optional Audio/Video Image Order” in media source to “vimeo thumbnail” and NOT to “featured image” as it is by default. This was probably the main thing, because when it’s not set this way nothing happens when I hover over the video’s thumbnail.

  • Also in media source, “item media source order” should be set to “vimeo video”

  • In grid settings / media playback , “Use Controls Inline” should be set to “enable” if you want to be able to pause the video and to go fullscreen.

  • I set the play button of my custom skin to Play Embedded Video instead of Lightbox, as Friech suggested.

Thanks again to the whole themeco team for helping me get to the bottom of this problem.

Hi Jerome.

We’re glad that you’re able to figure it out and thank you for sharing your solution. If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.