Error when moving classic image element since update

Hi,

My site https://thehorsleydirectory.co.uk has recently updated to the latest versions on Cornerstone and ThemeX, but now when I try and drag a classic image element to reposition it on the page I get the following error message:

If I then try and add a different element to the placeholder, the whole body section disappears:

The Cornerstone interface then freezes and I can only exit to the WP Dashboard.
I have only added custom CSS to the X customiser and have not changed any HTML.

Best wishes,

Brett

Hi Brett,

Thanks for reaching out!

There could be a plugin or custom code that affect your website.

I recommend the following troubleshooting procedures before we investigate the settings.

  1. TESTING FOR THEME RELATED ISSUE
  2. TESTING FOR PLUGIN CONFLICT
  3. THEME UPDATE
  4. CHILD THEME
  5. CSS/JS CUSTOMIZATION
  6. VERSION COMPATIBILITY

Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi Brett,

There’s additional verification when I tried to access wp-admin. I suggest that you disable that plugin for the meantime.

Thank you.

Hey Brett,

I moved the image and saw the issue you described but only momentarily. The image preview went back after a second (see secure note).

Please clear your browser’s cache and also try other browsers.

A reinstall of X and Cornerstone might solve the momentary display of the error.

Hope that helps.

Hi Christian and Marc,

Thanks for taking a look at my site. I’ve tried reinstalling Cornerstone and ThemeX and tested on other browsers as well as clearing the caches, but to no avail.

Rather than a temporary display issue, I’m getting a ‘permanent’ situation where I can move an image but then it locks in place and I can no longer move any images. Trying to add/delete anything results in the body section disappearing?

Thanks

Brett

Hello @brett101,

When you drag the image, there is a JS error that occurs on the page. It could be coming from one of the plugins which cause this conflict. As an alternative and for a faster solution, you can utilize the skeleton structure of the elements in the left panel and drag/drop the image element in which column you want it.

Check out the secure note.

Best Regards.

Hi Ruenel,

That’s great, thank you, and I think easier to see what is happening.

Best wishes,

Brett

Hello @brett101,

Glad that we were able to help you. Please feel free to reach us if you have any queries regarding our theme and theme settings.

Thanks