Edit with PRO not working/Broken

Trying to edit pages with pro it starts to load but I just get the circle spinning/loading forever.

Tried in Edge, Chrome and firefox - so something appears to be wrong.

It’s a pro subscription and up to date PRO theme so unsure what the problem is? Can anyone help?

I am having the same problem - Edit with Cornerstone does not load.

I can see these error in the JS Console:

TypeError: window.csGlobal.rivet is undefined
in /wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1

Uncaught TypeError: window.csGlobal.rivet is undefined

I am using the following versions of the X Theme and Cornerstone because when I upgraded to the latest version, the site became completely broken, so I had to recover from a backup:
Cornerstone: 6.08
X Theme: 9.0.8

Hi @mrg23,

Thanks for reaching out!

There could be a plugin or custom code that affects your website.

I recommend the following troubleshooting procedures before we investigate the settings.


Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

@tazulay, please follow the recommendation above, and if the issue still persists, please create your own thread and give us all your admin credentials in the secure note.

Thank you.

Hi Marc,
Have tried but struggling still. I also cannot see a secure note option to send you login details.


Hi Michael,

The issue has something to do with your SiteGround Optimizer plugin.

  • In X, Pro, and Cornerstone we follow all the WordPress best practices for managing front end assets (CSS/JS)
  • We also minify those assets ourselves with each release. You shouldn’t need to use another system to minify them again.
  • By “minified” I mean that we run post processing to convert our human readable source files into much smaller files. Variable and function names are shortened, whitespace is removed, and other techniques are applied to produce valid javascript that takes up the least amount of space possible.
  • When it comes to optimization systems, the burden of responsibility lies primarily with that system. Our files are valid javascript, and should be a valid input, but there is a possibility of failure if the system doesn’t properly parse and handle those files.
  • What happens periodically, is that optimization systems like SiteGround’s minifier will not properly parse code that is already minified, resulting in broken output. There is nothing we can do about this on our end.

Our recommendation is to disable the minifier entirely. Unfortunately, if you want to use it, there is the possibility of it failing.

Hope that helps.

Upgrading X to version 9.1.4 fixed it for me.
We’re on PHP 7.2, which is the highest PHP version supported by our host, A2 Hosting.

From the 9.1.4 release notes:
Bugfix: Fix fatal error when using PHP versions older than 7.3

Hi Marc,

Really appreciate your help I can now access the edit with pro (well it’s now changed to cornerstone, but same thing).

I’ve disabled and deleted the siteground plugin; sorry I am not very technical… and our web developer has disappeared off the face of the earth now!


Hi Mike,

You’re welcome! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

oh why did I not think of the minify thing, of coarse SiteGround automatically activate their plug inn. Ok solved, thanks for your input!

Have a great day

Hi @RPronk,

You’re welcome! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.