Double Looper Link

Hello - working with the Looper .csv beta and I’m getting a double link on import (ie. what cornerstone sees)
My csv input field is <a href=>LSC-6 2'P x 4'Wide</a>

Any help to make this stop would be appreciated.

Can you send me a screenshot of what you are seeing?

Are you clicking the “Link” icon button here and uploading through the media uploader?

Hi @Charlie

I’m loading from an external source:

Csv looks like ![Screenshot 2023-10-26 at 1.04.13 PM|690x143]

What I see in CS…

the red link when clicked tries to go to:

That’s about the entire process - please let me know if I can answer anything additional

Okay let me know if this helps. Check “Has Header” because that will help not loop the first row.

{{dc:looper:field key="LSC Sun Control"}} Would then grab the first column and any CSV like this you would just copy the very top column value and place it into the key section of that Dynamic Content.

How are you using the dynamic content? Are you using that as a URL or are you placing the dynamic content as content of a Text element? If you are doing the former I would place this in as text element content.


What I’m doing is creating a dynamic list of downloadable files. I want to create a list with links inside of an accordion, anywhere from 7 to 80 items in the list that are links to download a specific file, as opposed to creating each text field by hand and then linking to each individual file.

I currently have the looper on a Column which contains a text element and image element - and the elements are filling as expected, except for the weird link thing happening.

When I turn on Has Header- data vanishes, when I update the text consumer to {{dc:looper:field key="LSC Sun Control"}} the text doesn’t return while updating the image to {{dc:looper:field key="two"}} allows the images to return - not sure why images is working while text is not

If this will help clarify - - just a quick screen capture of applying the settings suggested

Also, no change when I load the csv locally from WP Media or changing column 1 header title to one

Okay I see now. You are using that LSC part in the looper provider field, when you can put it in the “content” field of the text element. If you click the “Setup” area here you will see it again. Uncheck the Looper provider as well. I’m a little surprised you got anything to output in the first example, but whatever is in content right now might give you a clue.

Let me know if that helps and have a great weekend!



Thanx, that makes a bit more sense now, however I’m still having the main issue of the double link -”http:/ that doesn’t work as it should - not sure why it is appending the host site in front of the link .


Any additional insights on this for the double link problem I am encountering?


I played around with CSV looper and tried to re-build you example with a google spreadsheet. Everything worked without a problem. Then I had a second look at your description, especially at the screenshot of your data table. I’m pretty sure there is a problem with the quotes of the url.

If you look very close to the screenshot you can see that the first url uses the wrong quotes.
In fact I was able to reproduce the double link behaviour if I use these kind of quotes: but you need to use these straight ones for urls: "


Thank you sir, you are a genius!
I’ve tried a ton of things to fix this and never saw the quotes difference!!!