Custom Fonts Display in Cornerstone, but not on published pages

I am currently redeveloping a WordPress website using Pro. I previously had a hybrid setup on this site using a mash-up of the Elementor-based theme/pages developed by a previous agency combined with some new pages that were designed by myself after I began working with this organization over a year ago (as of today it is still live at https://newlifeofnyc.org/). Across the website, including pages that were built using Pro/Cornerstone, we have used the organization’s brand font Kensmark 5 as a heading typeface (see https://newlifeofnyc.org/ways-to-give/).

It was high time we did away with the Frankenstein’s monster of Elementor theme + Pro theme with two page builders being used to manage different pages, so I have begun redesigning the entire site using Pro on a staging site (see https://1jw.429.myftpupload.com/). The problem that has continued to plague me, and I still cannot solve it, is that Kensmark 5 refuses to display on the website anymore. Once I switched to using the Personify: Mogul style for this website they stopped working. They will display in the Cornerstone page editor for what I am currently editing. If I am editing the footer, the fonts will display correctly in the footer, but not in the page that is being previewed above it. On the front-end none of the custom fonts display properly, but the Google fonts display just fine.

  • As I was looking through your forum I found that someone had a similar issue, and it was related to insecure content. I saw that I had a similar error on my site. But after installing SSL Insecure Content Fixer, and removing that error, the fonts are still not displaying properly.

  • I even went as far as to upload the font in more file formats (TTF), to ensure that there was no compatibility issue. (i previously only had WOFF and WOFF2 formats). This still did not solve the issue.

What else could possibly be preventing the fonts from displaying properly on my staging site?

Hey @ryankerbs,

Thanks for writing in!
Update your Pro theme to version 6.4.19 version first.

Please check your custom font name in the Font Manager.

Best Regards.

Thanks for the response.

I have updated the theme to 6.4.20 and I am still seeing the same error.

In regards to the font naming, I believe that is also set up correctly.

And this is how i set up the custom font


I previously only had the WOFF and WOFF2 fonts there, but in troubleshooting this also added the TTF file formats, but that did not seem to make a difference.

Did I do it right?

Hello @ryankerbs,

To help you with your concerns we need to check your settings, I would request please share the admin login details meanwhile I would suggest you troubleshoot a few of the common issues before we investigate your settings. Please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin-level username and password
  • Exact URL

You can find the Secure Note button at the bottom of your posts

Thanks

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Every page on the front end is not loading the fonts. Every one of them is supposed to have the Kensmark 5 font for all of the titles, but wherever it is supposed to show Arial is displaying instead.

Hey @ryankerbs,

I am seeing this:

This is NOT “Kensmark 5” font? I would recommend that you check the font name and test again.

Thanks.