cURL error 7: Failed to connect to / port 443: Connection refused

I see that such a problem has already been raised, but I don’t see instructions on how to deal with it so as not to create a page from scratch.

The situation is as follows:
I wanted to update wordpress, but a critical error appeared. I restored the site from a backup. Then I noticed that the theme license had expired. I bought a new licence, but it is not possible to activate it. After entering the code I get this message:
“Uh oh, we couldn’t check if this license was valid. Details.”
After clicking “Details” I get another message:
“cURL error 7: Failed to connect to
port 443: Connection refused”.

What can I do to activate the licence?

Hi Jacek,

Thanks for reaching out.
I have checked your Themeco Account and found that you have not added any URL to the location or in staging, that might be the reason why you are getting this error while validating the license. I would suggest you add the URL and check it once. If that does not help, there might be a few different reasons for this issue.
I would suggest you troubleshoot the common issues related to the Product Validation.

  1. Location Issues
  2. Communication Error Messages

If none of the above helps, please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


I have checked the suggestions for solving the problem. I still cannot carry out the verification. I do not know what this is due to.

Hi Jacek,

I have checked your website and found that you are using a much older version of X i.e. 4.6.0 and the Cornerstone version 1.3.0. The validation process has been changed a lot in the updated version.
As you are using a much older version, I would suggest you please copy your live site to a staging server and update the X theme and the Cornerstone in the staging by following the below steps.

  1. Delete the existing Cornerstone
  2. Update the X theme to the latest version on automatic updates.
  3. After the X theme is updated, use the link in the dashboard to automatically install the Cornerstone. It will be in the latest version.

And If everything goes fine in your staging please migrate the staging server to live and try to activate the license once again.


I’ll check it out and let you know if it worked.

Hi Jacek,

You are most welcome.

I updated the theme on the staging site. I had to do it with a manual installation, because I have the automatic update disabled because I can’t enter the license key. Unfortunately, after the update, there was a “critical error” in wordpress.

I tried use tips from this posts, but it is not working. All the time I’m getting message about “critical error”.
Important WP 6.2 Issue — Please Read Before Updating.
I did an upgrade of wordpress to version 6.2 on another theme, and every time the error appears when using theme X.
Do you have any other recommendations or suggested solutions?

Ok, error disapeared. For now. I have another problem, but I will describe it in other topic.

Hi Jacek,

If you already updated the WordPress version, you can directly upload the X latest version by downloading it from your Themeco Account and installing it by following the below steps.

  1. Delete the existing Cornerstone
  2. Update the X theme to the latest version on automatic updates
  3. After the X theme is updated, use the link in the dashboard to automatically install the Cornerstone. It will be on the latest version

If you are having trouble, please share the credentials of your staging server where you have updated the WordPress for further assistance.


On the staging page I did an update of the theme and wordpress (access in secure note). I think it worked, for now. Now I have another problem.
After the update, the content of the page broke. Instead of text, the whole code started to display. The graphics disappeared or became distorted. The header and footer are also unformatted. I refreshed the browser cache (ctrl + f5). After that, all the content of the page disappeared. Only the unformatted header and footer remained. When I go to edit the page, I can see that the content is there, but on the preview it does not display.
How can I fix this?

Hello @dylu_nld,

It seems that your homepage has been edited outside of Cornerstone which is why it is not displaying as blank. There are a 196 revisions to your homepage. It is best that you revert to the previous state.

  • See the secure note below

Best Regards.

Thank you, but I would like my old site to display. After the update everything disappeared. I restored the page from 8 months ago and all the content is invisible. The header is also in a different format than before the update.

Hi Jacek,

I would suggest you restore the website from the last working backup before the update and then please copy your live site to a staging server and update the X and Cornerstone.
If everything worked fine in your staging you can migrate the staging server to live.

NOTE: The backup you may get from your hosting service provider.

Hope it helps.

Ok, I did everything from scratch. I did a staging of the current site, with the old X and the old wordpress. I performed the following steps:

  1. I switched to the default theme to make the site safe for upgrading.
  2. I updated Wordpress.
  3. I removed Cornerstone.
  4. I removed X completely and then installed the latest version.
  5. I installed the current Cornerstone.

Unfortunately, my site looks like the attached image. It looks like something is wrong, but I can’t tell why. Restoring the previous version of the site did not help.

I add a picture of what the page looks like after the update and what it should look like (link to the live page - without the update).

Do you have any idea why this is happening?

I also don’t see an option to add a new or edit the old header and footer.

Hey Jacek,

I tried to validate your staging area and I was able to validate it without any issues. I don’t see any cURL error. On the other hand, on your screenshot, I suspect that the Cornerstone plugin is not activated when you take the screenshot because when I check the same page, it is showing like this.

To edit your footer and header content, you can change it in the theme options and find the settings for your header and footer.

Note: I change the permalinks to post name so that the builder will be accessible.

Hope that helps.

While I was waiting for a reply, I started trying to create the page in question from scratch. On this staging (security note) there is the problem I described earlier.
Regarding the editing of the header and footer… When I enter the option you highlighted, the editor opens, but I don’t have a preview of the changes I’m making.

Hey Jacek,

To preview a document in the Theme Options, click Cornerstone and open a document. A document is either a page, header, footer or a layout.

Once the page is opened, you can open the Theme Options tab again.


I understand how it works. But please see that if I click on the Cornerstone button, I only have pages to choose from. I do not have the option to edit the actual header and footer. In addition, if I select the main page for editing, it shows me the option to create it anew. There is no current content. On the other hand, if I click “Wirtualny Spacer” (it’s an option for an online tour of our studio - Virtual Walk), it also doesn’t show what’s currently on that page.