Cornerstone saving crashes the UI

I am having a strange behaviour happening to the Cornerstone editor.
Basically whenever I try to hit save the first or second time, the page output shows empty and the image attached to the page also disappears from the wordpress backend.

Here is a VIDEO sample of the error: link

It’s makes any updating virtually impossible, I had to recreate page over and over again to make it work.

I tried to disable the plugins aside from cornerstone to isolate the error, but no luck.
Using the default wordpress theme seems to work.
Help please

Hello @redleome

There might be a few different reasons for this issue, I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache
  5. Permalink Issue

I recommend the following troubleshooting as well.

1.) Increase PHP Memory Limit
2.) Increase PHP Execution Time Limit

I recommend increasing the following server settings to the specified value or larger. Please consult to your web host for all these server settings

PHP configuration recommended

memory_limit = 512M
upload_max_filesize = 512M
post_max_size = 512M
max_execution_time = 300
max_input_time = 300

If none of those work, It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi @prakash_s - the error still happens. When you edit a page in Cornerstone and load it 1-2 times, the content disappears. If you added an image to that post it also turns grey. 1 of the job post also gets cleared.

Hi @redleome,

Please double check your credentials because I am not able to login to your website by the credentials you provided.

Hope that helps and let us know how it goes.

Thank you.

Hi Marc,
Can you please try again

Hi @redleome,

I have created a page as shown in the video and updated and modified it multiple times, and didn’t find any issue described. Can you please check once again, and let us know if the issue still exists.
If that issue still exists, please let us know the steps to replicate it.


Hi @tristup thank you for testing it, I posted a new video showing the problem that I’m encountering. Is it possible that this is happening only from my end? I’m using Moz and Chrome to test, and I’m seeing the error on both browsers

Here is the video:

Hi @prakash_s,

I saw your comment from this post about Cornerstone and how it is saved as a Post type:

This sounds similar to an error that I’m experiencing…
–Did I understood that correctly? If I have a custom post type and I’m using the default editor from wordpress it can cause conflicts with Cornerstone? I have disabled all plugins on my site but the custom post type data saved from before are still in the WordPress database, could that be an issue?

Even after disabling the custom post type plugin it still doesn’t work tho…

1 Like

I am having this exact same issue. This is NOT a “you edited the page outside of Cornerstone” issue. Thank you for the video!

Hi, I think in our case it might actually be a conflict with our custom post types, do you guys have it on your site too @lwskcmi?? We have a separate post type for Job posts that doesn’t use cornerstone as an editor, its just using the default wysiwyg editor and saves its own meta to the db… I think its possible after the update that its triggering an error with that meta and the meta from cornerstone. It doesn’t explain why the image is also getting broken but that is just a my hunch, of course I could be wrong. Note that everything worked as it should before with the Post section only using the default Wysywig editor and pages using cornerstone.

It would be good to know if this is the issue from the Cornerstone team of course, so that we can avoid it if it can cause conflicts. cc @prakash_s

Hey @redleome,

The fastest way to check if this issue is only with Cornerstone is to deactivate all other plugins and switch to the parent theme.

If Cornerstone works fine without your custom post type, you need to find the issue with your custom post type. If we investigate the issue on your site, that would be custom development as we’ll be involved in working with custom code.

If Cornerstone won’t work with everything deactivated, the problem is highly likely in your database setup. We can investigate if this is the case but we couldn’t guarantee a fix as this is still beyond our control.

Thank you for understanding.

Hi @christian,

Revising my response, to simplify it:
I tested again with all of the plugins off aside from Cornerstone. It’s still not working.

Were you able to replicate the problem from your side? please check the video that I posted. It would be good to clarify if the error exists in the first place.

Thank you!

Hello @redleome

It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details of your staging site installation.

  • Staging WordPress Login URL
  • Staging website Admin level username and password
  • FTP details


No custom post types on our site. Cornerstone is just eating all of our content.

Hello @lwskcmi,

We will be responding to your other thread to avoid any confusion and getting off-topic.

Thank you for your understanding.

Hi, I got a staging version running now on our other server:

Hello @redleome,

It looks like there is something wrong with your server configuration.

See the secure below.


Hi Ruenel,

Can you please try the following link: I am using URL forwarding that’s why it broke.

Hey @redleome,

There’s still a problem. Please check.

hi can you please try again?