Cornerstone not usable anymore (2.1.3)

Hey guys,

I have upgraded to a new conerstone version and now I get the following error:

“A conflict on the front end of your site has prevented the preview from loading!” this is real bummer, could you help me out here. I did not yet remove any templates or plugins because it is on my production site and I do not have a staging setup currently.

If you need access to my website / hoster I can provide that.

All the best

1 Like

Hello Support,

I am currently no longer able to work on my website with Cornerstone!!

Please assist or advice I need your help.

I am having the same issue overhere.

1 Like

Have you changed anything in last days or was it only the update of the plugin?

I found at least an workaround. If you use the developer view in Chrome, you can delete the overlay which comes up through the JS error and can edit and save the page, so I guess it is an issue within cornerstone, would be great if someone from support would finally catch up here.


I have the same probleme… how did you do that? I don’t see what to fix in the developer view.

When I have refreshed the page it fixes it.

I’m having the same issue as well. Ran an update then Cornerstone disappeared. I uninstalled and reinstalled X and then Pro, hoping that would solve the issue. Deactivated all plugins but Cornerstone. Used a new browser never used with this site before.

It still doesn’t work. I’m on deadline. This is a HUGE problem.

Hello Guys,

Thanks for writing in! Most users rush to the updates and then if it does not work, tend to get frustrated which of course we always understand it especially if you are on a deadline. Before you update, we highly recommend that you always set up a staging area. This is very useful because you can test drive any X updates in the staging area, do the customizations and troubleshooting without disrupting your live site. Once everything is perfect, you can easily and flawlessly proceed the update in the live site. To know how to create a staging area, please check out these articles:,

Now, after doing the updates, you also experienced issue like Cornerstone no longer working. It has worked before the updated and after doing so, it does not work anymore. One of the major cause of this issue is caching:

  • You have have installed WP Super cache, W3 Total Cache or any other caching plugin. You must always clear your plugin cache right after the updates or slight site changes.

  • Other users are using minify plugins or applied minification for the JS and CSS. Well you will need to regenerate the minified JS/CSS files first after doing the updates.

  • If you are using CloudFlare, you must purge your site cache too.

  • If you are using WPEngine or Site Ground, there is a caching feature in the server which you will have to clear the site cache too.

  • If you are on BlueHost, they have Endurance Cache which could also pose a problem if the cache is not clear.

  • Other servers has Varnish. The Varnish cache must be cleared too.

Hope this helps.

Hello RueNel,

I think you are totally right by saying we need to check the updates in our staging areas but I guess you missed the point where there is a lack of quality in your software and we are having troubles now.

So as i cleared all caches and stuff please tell me what to do next as this error is continuing on my side. Is there a way to roll that update back until you have a decent fix for that bug?

On a second thoughtI find it also quite disappointing that it takes you more than 5 days to respond to an urgent topic, is there another way to get help in urgent topics faster?

Are you interested in looking into that topic? I can provide you with login credentials and access to my siteground hosting.

Thanks and best regards

1 Like

I can open the editor now but I am now unable to save any changes which is really annoying.

Anything I can fix that or is that just another bug?

All the best

Hi There,

Would you mind doing a plugin test? The error that we are seeing on the browser console from your site is not common and we cant replicate it on our end, so we can not say that this is a bug, but more likely with your site setup. If it’s not possible to deactivate all the plugins try purging the SG Optimizer cache and deactivate it for a while until we resolve the issue, also if the site is under an internal caching please deactivate it as well. This is to make sure that the site is serving us the updated resources and not a cached version.

Also, I advise to re-install the Cornerstone to make sure that there is no corrupted file due to fail update. The easiest way is to deactivate and delete the Cornerstone, then visit the X > Overview page so it reinstalls automatically.

If this does not resolve the issue, please provide us FTP credentials in “secure note” so we can investigate further.

Let us know how it goes,

Well I deactivated pretty much all my plugins and still I am not able to save. Maybe you could assist in reinstalling cornerstone because in “x<overview” I do not find any option to do that.

Would it also be an option to install the last version? I can provide you the FTP credentials in the secure note but for me this is currently really blocking my work :frowning:

You can also try to deactivate the plugins again maybe I did something wrong but I tried to flush all caches.

Best regards

Hello Johannes,

It’s quite unusual, but have you changed the default login page URL? I tried accessing admin page using and but it’s redirecting to page which seems to be the course login page and the credentials don’t work there too. Here is the screencast

I can login to the FTP using the details you have shared but I need to see the WordPress admin page for any changes that we make using FTP. Can you please confirm WordPress login page URL? If it’s something I am missing, kindly let me know.


Hey :slight_smile:

you can use this URL for the login:

And you can use the credentials in the first secure note

As far as I can confirm, it is an error in one of the cornerstone JS files.

Best regards

Hey @Johannes,

I can confirmed that there is a JS error in one of the Cornerstone files. And it is weird because it only happened in your site. We have tested X and Cornerstone in our local testing servers over and over but we cannot replicate the issue. Could you please give us access to your SiteGround and FTP so that we can manually update the files and check all other aspects why you are experiencing this issue. Could we also ask permission to update X and Cornerstone to the latest version?

Thank you in advance.

Hello RueNel,

you can update Cornerstone and X and you should already have my FTP and Website Credentials but I will give it to you again

Hopefully you can fix this issue as I am running behind my schedule already.

Thanks for your help

Hi There,

Maybe you could assist in reinstalling cornerstone because in “x<overview” I do not find any option to do that

Navigate to the X > Overview page, and X will automatically re-install the Cornerstone for you. I did reinstall the Cornerstone, Purge the SG Cache and deactivate, and that enable me to save page in Cornerstone (I added 2 empty section at the bottom of this page), if you still see the error on your end, please do a hard page refresh (ctrl + f5 / cmd + f5), or use your browser’s incognito/private mode.

Though that did not resolve the persistent error, we like to do a plugin test and try switching to your parent theme (maybe something on your child theme customization is causing the issue), but we can not really do that on a user production site since you have a lot of essential plugins there. Please setup a Staging Environment so we can further investigate the site.

How to Create Staging Environment for a WordPress Site

Thank you,

I solved one of the problemes by changing the template of the blog entry back to “Default Template” from “Fullwidth Layout”. I am still getting the initial error but I am able to save now.

So does that help to find the JS error on your side?

Best regards