Cornerstone not displayed/opening

Hi everyone!
I have a real huge issue with cornerstone and also for clients to whom I also recommended x-theme.

The thing is the following. I hired help for my client get his pages optimized for mobile. But both women, both from the philippines can do this, because Cornerstone doesn’t show. Neither on his nor on my site.
This is how the new page looks like - no cornerstone button

This is how the page overview looks like - no cornerstone links

This is how the menue on the left side shows - no x -theme/cornerstone links

And this is how she it looks wenn she clicks at the top x sign.
Then this opens - but she can’t click on any link.

These happend to both of the women!! while for me everthing works perfectly find on my website.
When I log into my clients website, I get a cornerstone link in the page overview, on the left menue and on the top in the middle - but there is no cornerstone button displayed when I open up a new page.

I never had such huge issues with x-theme and I really don’t know what is going on.
But we need really fast help, the pages need to be adjusted for mobile as ads are already running.

Please feel free to go and check things out on my website. I’ll give you access in the secure section.
Thank you for your help!

Hi Nimue,

Thank you for reaching out to us. Please check for the following first and see if this resolves the issue:


If nothing works then please get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.


Hello Nimue,

Please update your X theme to version 8.3.3. For more information on how you can update the theme, kindly check this:

At the moment, only the pages are allowed to be edited with Cornerstone. You can check it in X > Settings > Permissions > General. The first WP credentials do not work for us. And this how the WP dashboard looks like for the second given WP credentials.

Hope this helps.

Thank you Nabeel!
I’m doing my best to follow you, because I’m not a tech person :slight_smile:

On my site I have only 3 plugins (I just build this new one recently)

The theme was updated.
(I have a child theme - my client hasn’t but the problem shows for both of us. )

I’ve updated to php 7.4
I’ve changed the permissions also to pages,
but Cornerstone still doesn’t show for both of my VAs on

Thank’s a lot for your help!

P:S: I’ve updated the login information

Hello Nimue,

Thanks for sharing the login details. I went ahead and checked your site dashboard, it seems that it is working fine at my end. Please have a look at the screenshot in the secure note. It might be an issue of browser cache issue. I would suggest you clear your browser cache and then check it again or it would be best if you could check it in the private mode of the browser.


I think, I was now able to locate or pinpoint the problem better…
Because the problem is clearly happening on two different accounts (on mine and on our client’s).

Yesterday I tried assigning different roles.
Usually I assigned the editor role for people who work on different blog posts or articles.
When I assigned the editor role - cornerstone didn’t show. Neither in my nor in my clients website.
When I assigned administrator, it did work and conrnerstone was visible and clickable.

But aren’t there different roles, so that we can manage the access and different levels of rights people have who work with you? And shouldn’t it be possible to edit articles with cornerstone without being forced to grant everyone adminstrative rights, or am I wrong?

And it would be great if you could fix that! :slight_smile:


P.S: Please feel free to check out the ‘admin-cornerstone-problem’ on my site. If needed I can also provide you the access credentials of our clients website. Just let me know!

Hello Nimue,

Please go to X > Settings > Permissions > Editor > General and enable the “Post” and other features that you want the editors to have access to.

For more details, kindly check this out:

Thank you, that did it!!! I was my mistake!

Hi Nimue,

Glad that we are able to help you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.