Cornerstone loading very slow

Hello,

for some time I have the issue that cornerstone needs a very long time to load (over one minute!).
The problem appears on all my sites. Even on new and blank WP installations with only X-Theme installed.
My sites are hostet on Hosteurope and Strato.

It seems that the script "cornerstone-endpoint" causes the problem. It takes a very long time until it loads.

I have read some topics in this forum. Some other X-users seems to have the same problem.
There you said that the problem is caused by the hoster. I have contacted the hoster (hosteurope) and they say on their side it is everything good. They say the issue is caused by the script.

I hope you can help me and the other people with the same issue!

Thank you very much!

Kind regards,
Alex

1 Like

Hi there,

Thanks for writing in.

Have you recently updated it? It could be due to cache as it works and loading fast when I checked it. Or perhaps it's specific page, would you mind providing which one?

Thanks!

Hello same situation here.
My site is hosted at hosteurope.

What I've tried so far:
1. Ensure that PHP version ist 7 or later (7.1 in my case)
2. Update all X (6.0.4) and Cornerstone (3.
3. Caches cleard, including browser cache
4. I don't use CDN
5. Deactivated all plugins (except Cornerstone)
6. Check that custom CSS, JS and templates are removed
7. Inserted the lines:
define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );
in my wp-config.php

Unfortunately cornerstone still loads very slowly. Once it has started, it sometimes does not show the content of the pages and freezes occasionally.

Thanks for helping,
Andreas

1 Like

Hey Andreas,

Please open a separate thread and give us WP admin and FTP access in a Secure Note. Also post a link to this thread for reference.

Thanks.

Hi Rad,

thanks for your reply!
what should I update? It is a complete new WP installation with current version of X and Cornerstone.
The issue occurs on every page. Every time when I open the cornerstone editor.

To reconstruct the issue please
1. log in
2. navigate to pages
3. click on "edit with cornerstone" at page "test"

Thanks for your help

Regards,
Alex

Hey Alex,

I see that it takes a long time to load. Please contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

I have read that your host said there's no problem on their end but this is a hosting performance problem. Otherwise, Cornerstone would be slow in our test sites too. If you can, please try out other web hosts. Here's a guide.

Thanks.

Hi Christian,

thanks for your reply!
My hast hast tested the site on faster servers with a Memory_Limit of 512M
There was no result.

After hitting the button "Edit with Cornerstone" the Database starts a connection. The Status is on "sleep" for about 80s. This means that MySQL-Service is waiting for an answer of the script and the connection ist closed.
Do you know what is happening during this time and which data is the DB waiting for?

Thanks for your help!

Regards,
Alex

Hi @afinkdesign,

I saw one thread like this and the fix that I saw is that he followed this link below.

Let us know how it goes.

Thanks.

Hello Nico,

thank you very much for your reply!
But the troubleshooting does not work for my problem.

  • In WP-Settings both URLs are the same
  • I do not use https --> only http
  • There is no plugin conflict because there are no plugins installed

I have activated the debugging mode and this was the result:
PHP Notice: A non well formed numeric value encountered in ...../themes/x/framework/legacy/cranium/headers/output/masthead.php on line 143

I really hope you can help me out!

Thank you very much!

Regards,
Alex

Hello there,

I've checked line 143 in /themes/x/framework/legacy/cranium/headers/output/masthead.php and its pointing to the logo image in X > Theme Options > Header. However, it seems your logo image configs are properly placed. I can confirm your Cornerstone is loading slow in Pages, but not from X > Cornerstone.

Can you share us your FTP login details in a Secure Note we can take a closer look?

Thank you.

Hi Jumar,

thanks for your reply!
I have updated the secure note with ftp credentials.

Thanks for your help!
Regards,
Alex

Hi there,

The FTP credentials are still incorrect. But I checked again and the loading speed varies, it could be affected by traffic. Or yes, with database issue related to MySQL's sleeping processes. Have you tried getting more information about this sleep issue? It could be related to this https://stackoverflow.com/questions/47332640/wordpress-mysql-sleep-connection and https://stackoverflow.com/questions/48153782/wordpress-sends-lots-of-sleep-sql-query-to-mysql

I have same theme and builder on my local and live site but I'm not getting this issue. I also recommend testing it on another host.

Thanks!

Hi Rad,

thanks for your reply. FTP credentials are working for me …
Honestly I do not know how to figure out more about the sleep issue.
I would really appreciate if you could take a look. (please see DB credentials in secure note)
Thank you very much for your help!

Cheers,
Alex

Hi there,

Unfortunately, It’s not something I am not fully familiar with. I may harm it more than fix it. But sleeping could occur anytime when a script is taking time to end or process. Hence the cause is varying depending on which is executing, the database load, and server traffic. All in all, it’s about performance. Are you on shared hosting? It can happen on shared hosting.

Or sleep issue is not the cause but the result of the builder’s loading too slow, and it’s too slow due to performance issue. I recommend loading it on a separate host just for testing and comparison. This isn’t happening on my site.

Thanks!

Hi Rad,

thanks for your reply!
The Hosting-support thinks that the sleep-status is caused because Cornerstone has problems with the settings of Apache-Server (NGINX).

Could this be possible?

Thanks for your help!

Regards,
Alex

Hello there,

Thanks for updating in!

I’m not also sure but let us try to double-check your NGINX configs. Please the solution on this thread:

Let us know it goes. Thank you.

Hi Jumar,

thanks for your reply!
What do I have to do with this code?

Thank you very much for your help!

Reards,
Alex

Hello @afinkdesign,

Thanks for updating thread.

First take a backup of the config file. After that try replace that comprehend PHP with the code shared in the thread.

Thanks.

Hi Prasant,

which config file? WordPress-Config file? NGINX config file?
I do only have access to Wordpress config file.

and which code do I have to replace?

Thank you!

Regards,
Alex

Hi there,

You’ll have to do it in NGINX config files but as you said, it’s something you can’t access then I recommend forwarding this issue to your hosting provider. And I do see previous tickets related to NGINX, it’s not the same and easy as Apache config file.

Thanks!