Cornerstone and spinning wheel problem

I updated the theme to the latest version available but I have a problem with Cornerstone. I just see a spinning wheel instead of the builder loading.
I cleaned the browser cache but it doesn’t solve the problem.
I use Chrome and Firefox, updated to the latest version available.
I read the faq that suggests purging the plugin cache but I have no idea how to do this.

I provide the password to access my site.

Hi Daniele,

Thanks for reaching out.

The reason for that is because the cornerstone endpoint returns 404 which is unusual to cause by an update, because it’s been there since older versions. It could be due to security that blocks it, I did some initial checking with no luck. Perhaps you can backup your site before I do further testing? I like to disable everything and test it, it’s a lot from there so that staging might have your development site and testing it could alter what’s already there.


I backed up the site before updating to the new version of the theme. You can do all the necessary tests.

I’m having the same problem, can’t update any of my pages because I don’t get passed the spinning wheel as well. hope you find the problem soon!

We need an update as soon as possible.

Hi @danielemeo,

Would you mind updating to the newly released X version 7.0.3 and Cornerstone 4.0.3? Also you might need to have your PHP memory limit of your site increased.

To do this, please edit your wp-config.php file and insert these lines:

    define( 'WP_MEMORY_LIMIT', '256M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

Here is a details article about the PHP Memory Limit that is in our Knowledge Base:

In case the issue persists, please try to get in touch with your hosting provider and confirm to them that your PHP memory limit is increased.

Hope this helps.

Hi @KnapStaaltjeWerk,

Kindly try the solutions suggested in this thread. If the issue persists, kindly post a separate thread detailing your issue. Thank you.

Hi @Jade,

I update X to the version 7.0.3 and Cornerstone to 4.0.3 but does not solve the problem.

The PHP version installed on the server is 7.2.22

The value of memory_limit is set to 1024M.

Hey Daniele,

Would you mind giving us cPanel access so we could check your server and WordPress setup?


I updated the secure note with cPanel access.

Hello Daniele,

Thanks for updating the thread.

I regenerated the .htaccess file by renaming the current file and then from WordPress permalinks section to regenerate the file. Now pages are loading fine in Cornerstone. Please make sure to clear cache before editing the page in Cornerstone.


Thanks @Prasant

now Cornerstone is also loaded on my notebook, but I see that all plugins have been disabled and the site on the front end is not as before. Can I re-enable them or is there any plugin that creates problems?

I also have to update my other site. Can I proceed alone? Is there any procedure to be performed to avoid breaking the site?
Also here I have to regenerate the .htaccess file?

Hello Daniele,

Thanks for updating the thread. :slight_smile:

You can reactivate the plugin one at a time. In case issue shows up again then most probably plugin conflict is causing further issue. In that case you can reactivate one plugin one at a time to narrow down.

I checked the website and can see that website is running X 6.5.5 and Cornerstone 3.5.4. I suggest you to take a look at our update guide for instructions one update X Theme and Cornerstone:

Not necessarily. In case you face any issues, please let us know and we will take a closer look at the setup. Regenerating .htaccess is not the very first step to resolve the issue.


Hi @Prasant,
the problem would seem to be the Polylang plugin. If disabled, Cornerstone loads correctly.
This is a problem because the site is multilingual :frowning:

Could Cornerstone be made compatible with Polylang? Before the upgrade it worked well.

Hello Daniele,

Thanks for updating the thread.

I installed Polylang plugin on my local setup, made the necessary configurations and then loaded pages in Cornerstone. On my local setup pages are working fine without any issues.

I also see that you have caching enabled by the hosting provider. To me it seems like a internal cache issue in that regards, please get in touch with the hosting company and request them to clear the cache. If possible for some time ask them to disable all caching functionalities on the website. Once that’s done, please clear browser cache and reload the pages in Cornerstone and see how it goes.

As you need Polylang on the website, you have the option to rollback the updates to previous state. Here’s a tutorial that you can refer:

Let us know how it goes.


Where can I see that a cache system is activated on my hosting? On cPanel I don’t find any cache options or maybe I don’t know where to look for it.
This information could be useful to contact the hosting technical support and let them know the problem and then clear the cache.

Hi Daniel,

The internal cache is only a guess we’re not fully familiar how each hosting handles their internal caching. Some uses a plugin like on SiteGround, some may completely hidden. I recommend contacting the hosting provider about that issue. Have you tried cloning your site into different host environment just to confirm this?

And please try downgrading your Polylang version, though the current one should have no issue.


The technical support of my hosting provider replied that no caching system is active in the system.

So I think there is some incompatibility between Cornerstone and Polylang.

Hey Daniel,

It looks like you’re right. We have other reports in this other thread. Regretfully, we haven’t found the exact cause yet but it’s highly likely due to conflict with not only Cornerstone and Polylang but also the environment setup.

For now, please revert to a previous backup or working state of your site.