Clear stack styles

Hi, i can’t find where to change font styles.

I have use roboto in my theme options but in my contact page i see that use lato, i can’t find where to change it

Hi @Mastres,

Thank you for reaching out to us. You can clear the style cache via X > Settings > System and clear the style cache (see screenshot)

I reckon you’ve server cache enabled too, please clear that as well and see if this resolves the issue.

Let us know how this goes!

Yes, i tried both and didn’t work

Hi There @Mastres

Once you set your font in the font manager,

You also need to apply them into your elements. You can check our guide to see if you have setup correctly (

If you have done that correctly, you can then clear full cache by following this guide (

In case if you’re still having issues, please provide us with your WordPress login credentials in a secure note to check your issue further.

Let us know how it goes.

Hi i clear every cache and still don’t work the elements are V2


Hi Mastres,

In that case, please provide your admin login credentials and we’ll check and test it directly. Please provide it in the secure note.


Here you have

Hi Mastres,

There seems to be something that is stopping the body font to be updated. Here are some things you can try:

#1 Disable your cache plugin and see if the body font gets updated.

#2 Update X and Cornerstone to the latest version. Here is a link for details information on how to do an update:

Please remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors or any unexpected display issue on the site.

#3 Instead of using a Raw Content element for the texts, try adding a Text element to the builder and move the text from there. That way, you will be able to select the font that will be used to the text in the settings available. In case you are not seeing the options to set the font family of the text, please check your preferences settings and enable the Advanced Mode feature. Please click on the cog icon on the settings area then enable the Advanced Mode option.

Hope this helps.

Hi, i have check all steps, and still use body font. I will change elements, but what about the form? still have lato font

Hello @Mastres,

I have already logged in and checked everything. The typography should load Roboto into the page since the global body and content is set to it and yet it isn’t loaded. It could be because of your site caching. Does your hosting provider have a site caching mechanism or probably have Varnish installed. Maybe you can ask them about any caching features perhaps. I already have test everything. Even changing the fonts and adding more font weights. All my changes were not reflected in the frontend which seem to be a caching issue.

Please let us know how it goes.

Hi, i used siteground plugin cache, i have erase cache from plugin, in the server and asked host to erase his cache, nothing worked :(, i will do the page again and see if work

Hey @Mastres,

Yes, please let us know when you have recreated the page and still has the same result. Maybe you could also set up a staging site so that we can compare it. The staging site is very useful because we can test drive the font changes, any X updates in the staging area, do the customizations and troubleshooting without disrupting your live site. Once everything is perfect, you can easily and flawlessly proceed the update in the live site. To know how to create a staging area, please check out these articles:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.