Change MEC events body font color?

I can’t seem to find where to change the color of the body of MEC

See here how it is grey and barely visible, I want it to be black and more legible.

Thank you!

Hello, still need help on this.


Hey John,

Thanks for reaching out!

I am not quite sure about the MEC events body font color, would you mind sharing more information? Providing screenshots or video is a great help.

See how the text in the body of an MEC post is colored grey?

It’s too light and I want to change it to black, but I can’t seem where the setting is to change this text

Hello John,

Please go to M.E.C. Calendar > Settings > Appearance and there should be a color picker for the Content of the Calendar single.

Best Regards.

Hmm ok, I tried changing that Content color picker to black, but it doesn’t seem to affect the body of the event.

I also did clear all cache and try again

Could there be another global setting affecting this from taking affect?

Hi John,

It seems that the selected colors do not apply to the content in the front end. I would suggest you, please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Ok great, here is the login info, thank you!

Hi John,

It seems that the MEC plugin has hard-coded the color of that element. When I inspected the page, I see this custom CSS code in the plugin styles:

.mec-wrap :not(.elementor-widget-container)>p {
    color: #616161;

You can use the example code above and change to your desired color and then you can add the final code in Cornerstone > Theme Options > Custom Code > Global CSS.

Be advised that custom coding is beyond the scope of our support under our Support Policy. If you are unfamiliar with code and resolving potential conflicts, you may select our One service for further assistance.

Best Regards.

Hmm, so I added it as you suggested, and changed the font color to #000000 for it to be black, cleared my cache, but it is still not taking affect?

Hello John,

Your code is correct. Change it temporarily to red to see the result and it is applied to the page.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.