Cant change fonts on anything

Hey there,
So it appears that all my fonts seem to ignore all of the settings in the Customization settings for Typography. It doesn’t matter what font I pick, everything remains the same. I set up Typekit with a kit id and still nothing.

I am using X Theme 6.0.4 and all plugins are up to date.

Hi there,

Thanks for writing in! I’m sorry that you ran into trouble with this. I see a 404 error related to Typekit in browser’s console. A 404 error means that your kit has not been published yet.

To publish the kit, go to and click the publish button.

You will need to republish the kit each time you make a change, such as adding new fonts or changing the language setting. Also see

Please give that a try, and let us know if you still have problems with the fonts loading.

Thanks for the help. I hit Publish and now I do see my font shot up in Typekit. However, I still have the problem of nothing updating when I change a font. For example, if you go to the home page and hit Customize > Typography and try and change the font on the headers - nothing changes. Its almost like the H tags have no stylesheet or something.

I’ve used like 10 versions of X before and this is the first time I have run into this. I just installed this one yesterday, so maybe there was something missing in the upload? Anyway, thanks again for the help!

Hi There,

The heading elemnt work fine with the custom font.

Not sure if you have the issue with any particular page or section.
Please confirm.

Well thats odd because my headline looks nothing like that.
When I inspect the element it is literally: Helvetica,Arial,sans-serif with a font size of 1em.

I opened up a new Chrome Incognito window to clear cache and it still looks the same.
I even tested it in Internet Explorer and it still looks the same so I have absolutely no clue how youre seeing what youre seeing.

In addition, when I am scrolling through my list of available fonts, my Typekit font isn’t there anywhere.

After doing further digging its appears as though the “Classic Custom Headline” element actually works properly. The new “Headline” element does not. And my Typekit fonts do not show up under Typography.

I gotta be honest, me spending most of the day trying to figure this out and having to wait hours and hours for a response is getting a little old.

I decided I cant wait for a solution so I am just going to force the Headline element to function how it should by manually adding custom CSS for it. Pretty lame if you ask me. But in the end at least I got it working.

Hi @crobley,

Happy to hear that it is working already. I will forward this thread to our developer so that they could look on this further because this could be a bug.

Feel free to ask us again.


Well unfortunately my fix didn’t go very far.
For some dumb reason when I change the font family of Headings in the Font Manager of X it only applies to the H1 tags. H2 tags ignore this setting. Since I am using a TypeKit font - I am unable to add css to a H2 class with the typekit font. It simply does not work.

I need a solution to this font problem and so far I have received ZERO help from support and its been 2 days. Not one of you has offered a suggestion on how to fix this. What is going on??

Hi There,

Like on your other thread with the button color issue, I also investigated on this and I don’t see any issue, its just the V2 Elements does not directly adhere to the Theme Options settings directly.

This is just a matter of using the Font Manager feature properly. I see that you successfully set the “Verveine” font on the Font Manager, but you disable the Font Manager option in the Theme Options > Typography, please enable it and set the HEADINGS FONT option to your “headline” font-template.

Hope it helps,

Wow the font stuff can get so confusing! I feel like there 5 different font adjustment locations.
In any case, that did help me out. Thanks for the help.

You are very welcome :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.