Blog Masonry Not Appearing


I have my blog post setup to the global layout. In theme options, when my style is “standard” everything appears fine, but when I switch it to “masonry” it all disappears. I have checked for css code, interfering plugins, disabled the cache, and I don’t have a child theme. Help? It’s for a client site.

Hello Cassidy,

Thanks for writing in! Could you please update to the latest versions?
Our latest versions are:

  • Pro theme 4.2.3
  • WordPress 5.7
  • PHP 7.4

This latest release contains fixes for several issues so be sure to check out the changelog:

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

If the updates are not helping, provide us access to your site so that we can check your settings and investigate the issue further. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Please let us know how it goes.

Secure note info has been added. Everything is up to date.

Hi Cassidy,

It seems that the issue is due to the minified version of JavaScript file, which don’t run the code for masonry layout. I would suggest you temporarily disable the minification. If that works for you, I would recommend you to exclude the theme JS file(s) to be minified.

Hope it helps.

Thank you!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.