Blank page when trying to edit page and not all Design Cloud elements loaded

I just installed Pro on a new site and tried to import a design cloud theme. Not all elements came in and when I go to edit a page it only shows header and footer and slider. Is there a way to repair the upload of the design cloud element (for example this home page installed the Blog Slider)

Hello Ethan,

Thanks for writing in! This issue could be caused by a plugin. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

Testing for Plugin Conflict
CSS/JS Customization
Disabling Cache (SG Optimizer)
Disabling CDN

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

wow, I had disabled all of my plugins but SG Optimizer. That fixed it.
Thank you so much.

Now what about being able to reinstall the pre-made site? It doesn’t look anything like the template.

Hi Ethan,

Great that it resolved the issue, I would recommend you to import the specific demo once again. If you get any problem during the process, I would suggest you reset the database using the following plugins from WordPress repository and try to import again.


Please remember that you may need to re-validate your license once you reset the database. If that does not help, please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Hi Ethan,

I have gone through your site, and every element is loaded properly while editing any page in Content Builder. Checked the Home page as mentioned in your post, and it is loading all the elements. Can you please check if the issue still exists on your end?
If that is not the case and you are trying to point out something else, please provide any screenshot marked with the issue or any video that helps us to recognize the problem.


That is not the correct slider on the home page

Hi Ethan,

It seems that the wrong slider has been selected for the Home page. There are two sliders in Revolution Sliders, App Blog and App Home and App Blog selected for the Home Page. If that is not the correct one, please edit the page through the default editor and select the correct slider.

Hope it helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.