Almost all Google Fonts not loading except a few

When attempting to use a Google Font, almost every single Google Font does not actually load on the website and insteads uses a default sans-serif or serif font instead. The list of fonts in both the Font Manager and the Heading/Body options in the Theme options are populated with all the Google Fonts, but only a few (like Montseratt) will actually work. This has happened on multiple websites and I’ve just worked around it, mostly just using the font Monsteratt, but I would like to get this figured out and hopefully use a different font for once.

Hello @turbineflats,

Thanks for writing in! To better assist you with your issue, please provide us your site URL so that we can investigate. it would also help if we can log in to your site. You can create a secure note in your next reply with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
– Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

image

In the meantime, please check out this documentation to resolve the most common issues that may have caused your issue.

Best Regards.

Thank you for the response, sorry for my late response. I added a secure note to my original note with the information you requested.

Hello @turbineflats,

I tried to access your site but I am not able to access the site login page due to invalid login details on the popup login form, please recheck and send us again.

Thanks

I apologize, I’ve attached the correct password in a secure note.

Hello @turbineflats,

I have log in and checked your site. The Google font is loaded as expected.

Please see the secure note below.

Thanks.

If Roboto was the only font that you checked, please check another font like Oswald or Ubuntu - please check more than one font. Roboto is one of the very few fonts that does load actually load.

Hi @turbineflats,

I have checked your website and found that the Oswald font is not added, I have added it and created a test page and it shows perfectly fine.

https://truckbay.flywheelsites.com/font-test/

Thanks