Align logo and menu button in custom header properly?

Hi folks,

I’m having trouble with the mobile header on

Header is called “rest of site”

Can’t seem to get the logo to align left and the burger button to be on the right.

I’ve set it up now with a row inside the container in the bar but they are still not aligning properly - i want the logo to be justified left and the button to be justified right to the outer margins of the page.

Can you please advise how to fix this as wasting way too much time here - the Bar element itself doesn’t seem to allow me to configure it.

I’ve attached the login details in a secure note below.

Thanks in advance

Hi Stephen,

Thanks for reaching out.
I have checked your Home header and found that you have added the Logo and the Navigation Layered in two different Bar and that is why it is showing one after the other. To show those in a single line, please add two different containers and add the logo and Navigation Layer into that.

Hope it helps.

As mentioned above it’s the other header - Rest of Site that is causing the issue, could you please have a look at this for me thanks.

Hi Stephen,

On other pages where the header is assigned it shows the logo and the Navigation Layered element in a single line as expected.


Hi this is not actually aligned the way I want it though, the left most point of the logo does not line up with the left border of the other content on the page below.

Similarly the rightmost side of the burger button does not align correctly with the right side of the page content.

It is almost as if there is a margin or some padding but I can’t find where this is coming from, I disabled global container on the rows on the pages but couldn’t see any option for this in the header builder

Hey Stephen,

The space you’re referring to is the Bar’s Gutter.


To fix your issue, you need to enable the Global Container so that if you’re using the Global Container in your content, they will have the same Max Width as the Site Max Width.



Thanks Christian that seems to have solved the problem for me. Much appreciated!

You are most welcome, Stephen.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.