Adding image to Slider

Hi,
I tried adding an image to a stacked slider (using the new Slider element) but it didn’t do anything (didn’t allow me to). Then I tried making the background of the slide an image, and it shows up correctly in Layout Builder, but does not display correctly in browser, see attached.

The url is

How do I get the browser to display the image the way the layout builder does?

Thanks,
Dave

Hey David,

Thanks for reaching out!

Would you mind sharing your credentials so that we can check your setup correctly? To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi,

You already have my credentials I believe from a previous topic. However, I “fixed” the problem. The issue was the default content of the Stacked Slider element has a Headline element within each slide; if I removed the headline element and then tried to add an image element instead, the slide would not allow me to add the element. However, if I kept the default headline element and added an image element beneath it, that worked, then I had to simply remove the headline element.

However, I have now run into another issue, which is that in Pro v4 I was able to change column ratios for different viewports (such as from two-column on desktop to one-column on mobile). This is no longer the case with v5? My slider on desktop uses a 2/3 to 1/3 row (with the slider on the 2/3 column and a headline element on the 1/3 column), and I wanted to make it 2 equal columns on medium viewports and single column on mobile, but when I use the new interface in v5 if I make a change to a row on any viewport it forces that change across all viewports. There must obviously be something you changed in how this is done, not sure why, but how do I acheive this effect in v5?

Hi David,

Glad that you are able to solve the issue. Regarding the Column ratio, you can still change that by clicking on the Template label under the Layout option, please find the screenshot describing the settings.

Thanks