Adding Categories blocks to products page

I’m trying to add a products page with categories, but for some reason my product page is not showing.

Now the next image is what my page is showing.
Not sure if there is some settings I’m missing?


Hey Ivy,

I believe you’re using WooCommerce for your product display. WooCommerce is a 3rd party plugin and it’s the WooCommerce support team that handles issues and questions about WooCommerce functionality.

Most WordPress support, including us, would ask you to perform certain steps to determine where the issue is coming from, and for this case, you should do the following.

  1. Testing For Theme Related Issue
  2. Testing For Plugin Conflict
  3. Theme Update
  4. Child Theme

If the issue persists using the default WordPress theme like TwentyTwenty and no other plugins are active except WooCommerce then it’s an issue with WooCommerce. You need to contact WooCommerce support if that’s the result.

I just like to add that we have a service called One where we can answer WordPress questions even outside of our themes and plugins. If you’d like us to answer questions about 3rd party plugins, please consider subscribing to One.

Thank you for understanding.

Hi Christian,

Thank you for the response.
I would like to know why my sales page looks like this: - as per picture uploaded.

and my product page like this? .
It just seems to me that I’m missing something because it looks different to all the pages.



Hey Ivy,

This could be due to your setup, to better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:


Hi Nabeel,
Thanks for the quick reply. I’m working on a local host so I can not give you access, but I discovered once I add products the categories shows. Maybe as you said it was the settings not showing if there is no products in a category.
Sorry for the inconvenience, but I’m still learning.



Hi Ivy,

If you want to display Product Categories in your shop index, simply go to Appearance > Customize > WooCommerce > Product Catalog and select “Show Categories and Products”.

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.