Add Revolution Slider to main blog page


I am trying to add a slider (Revolution Slider) to the top of the main blog page only. I have tried several suggestion from the forum and cannot get it to work. The blog is not the homepage of the site and we are using the Integrity child theme.

Thanks very much for such a great product and any assistance that you can provide.

Hello @PagnatoKarp,

Thanks for writing in!

Please use the solution shared in following thread:


Hello again,

We have already tried this solution (along with several others) and it is not working for us. As a reference, it also does not break anything. The script was changed with the appropriate slider name and child name, and the wp-index.php file was put in the correct folder location.

Any additional help/suggestions would be appreciated. Thanks very much.

Here is the script as we are using it:

<?php // ============================================================================= // Slider on Blog Configuration // ============================================================================= $is_filterable_index = is_home() && x_get_option( 'x_integrity_filterable_index_enable' ) == '1'; ?> <?php get_header(); ?>
<?php //x_get_view( 'integrity', '_post', 'slider' ); ?>
<?php echo do_shortcode('[rev_slider alias="blog"]'); ?>

<div class="offset cf">
  <div class="<?php x_main_content_class(); ?>" role="main">

    <?php if ( $is_filterable_index ) : ?>
      <?php x_get_view( 'integrity', '_index' ); ?>
    <?php else : ?>
      <?php x_get_view( 'global', '_index' ); ?>
    <?php endif; ?>


  <?php get_sidebar(); ?>

<?php get_footer(); ?>

Hey @PagnatoKarp,

Let’s try a different approach here. Copy and paste the following code in your child theme’s functions.php file:

function x_add_blog_slider() {
    if ( is_home() ) {
        echo do_shortcode('[rev_slider alias="church-home"]');
add_action('x_after_site_begin', 'x_add_blog_slider');

In the above code just change the Revolution Slider shortcode '[rev_slider alias="church-home"] with your own. Let us know how this goes!

Thanks for alternative approach. Unfortunately still not working (shortcode was changed to the correct one).

Hello @PagnatoKarp,

Actually the code given by @Nabeel works. The slider is already in your blog index page:

You are not seeing the slider because of caching. Please clear your WP Rocket cache or temporarily disable all your caching plugin and minify plugins. These plugins are best to turn ON when you are done building your site and ready to go live.

Please let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.