ACF field not displaying

Advanced Custom Fields are not displaying. I’m using text elements to pull in content from acf.

It seems to be a conflict on pages that have loopers and consumers in use.

I created a test page with nothing but my acf fields and it works. As soon as I add a new section in which I created a looper consumer relationship there was a problem. There also seems to be some difference depending whether the section containing my custom field content comes before or after the section containing my looper.

Hello @Sheri17,

Thanks for reaching out to us. To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Unfortunately this is on my local test server so I can’t give you remote access. Are there specific things you want to check? I can provide you with any answers you need.

I first noticed this on an existing page and my first troubleshooting step was to create a new page.

On the new page, I created a section with nothing but text elements that pulled in the five ACF values from the page. It worked.

Next I added a section that had rows and columns in a looper provider/consumer relationship.

When the ACF text elements section is first, everything works. If I drag that section below the looper section, the text elements stop pulling in ACF content. If I return the ACF text elements section to the top it works again.

Please let me know if you have any other questions or if there’s anything you’d like me to try.

Hello @Sheri17,

It would be best if you could upload your site to the staging server and please share your details of the staging server so that we can investigate your setting without breaking your live site.

Please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


I’ll see about setting up a staging site where you can see what I’m talking about. I’m working on a deadline though.

I’m not the only one to post here about unexpected behavior with ACF. I hope you are investigating the issues whether I can make a staging setup for you or not.

I’ve created a test instance for you. It’s on a brand new install. I’ll provide access info in a secure note. There’s a page called “Test ACF Page”. It has a looper section and an ACF section. Right now the ACF section comes first, and you can see everything both in the content builder and on the frontend.

If you drag the looper section above the ACF section and save it, you will no longer see the acf data on the front end.

Hey @Sheri17,

Thank you for setting up staging to show the issue. That really speed things up as we can see the exact setup that leading to the issue.

I’ll post this issue in our tracker so it will be queued to be fixed by our development team

1 Like

Thanks! I need to be able to use ACF for my current project. Does it look like the issue is with ACF specifically? Would creating my custom fields a different way possibly work?

Hi @Sheri17,

It seems like that the issue is with the ACF, It has been already reported to our development team to investigate and queued to be fixed. I would suggest you go through this article to get an alternative solution,


The test site had completely crashed. I restored it and updated to 4.0.8. The issue is still the same.

I have increased all my php settings to your recommendations. That had already been done on the site where I first noticed the issue, but I made sure it’s the same on this test site.

I got this issue initially on the test server with no plugins installed so this isn’t due to any plugin conflicts.

Let me know if you have any questions.

Thanks for the link. I did get it to work with a different custom fields plugin, but I’d prefer to stick with ACF

Hello @Sheri17,

It’s great that you are able to get it to work with other plugins. Regarding the ACF, my colleague has already reported the issue to our development team to investigate and queued to be fixed, please stay tuned for succeeding release with the fix.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Hi @Sheri17,

I’m sorry we’ve not been able to get to this sooner. Thank you so much for your assistance with the test site. It wasn’t specific to ACF, but rather an issue with the original post not being reset when the looper concluded. This means your page was trying to pull custom data from the last post in the looper unfortunately. I’ve been able to identify the problem here and get it corrected for the next point release.

1 Like