Youtube Embed video not playing and on iOS black with line through it

Hi, Using X Theme with Cornerstone site has been running for 5 years no issues but now embedded Youtube videos are not playable. One example:

This uses the Classic Video Player element. I have tried setting up with the new Video Player element but that just shows a white box with the youtube URL in black at the top.

I see there are similar posts where this resolved itself but that has not happened here.

Have tried clearing cache with current host but no change. Could use help here please.

Hello @rogermedia,

Thanks for writing in! I have checked your page and even on desktop screens, the video cannot be played because the controls were disabled. Please edit your post and turn ON the video controls. You might as well set it to Auto Play.


We would love to know if this has worked for you. Thank you.

Hi, I have had the site setup for 5 years and it was always setup to play from the Youtube controls. Was this a recent change?

I turned off the Hide Controls and it plays now but I would prefer to have the giant Play button from Youtube control the video. Is there a way to enable that?

So it looks like I need to change everything to the new Video Element and then add the iframe embed code from Youtube to have the Youtube player functionality? What a mess. I know that this used to work in the classic element. Is there a way I can either revert back to the way the classic element worked or is there custom code I can add?

I would prefer not to update over 100 posts and pages with this issue.

Hello @rogermedia,

Please be advised that you are using the embedded video element which means that the video is embedded. Anything that displays like the controls are coming from Youtube itself. The embedded video element is merely a container to display the Youtube video inside the column element. The element does not have any option for you to be able to insert a Big play button.

Hope this helps.

Yes the embeddd video is what I had originally. Something was updated in the theme/cornerstone at some point to change this. Is there a way to revert the Classic Video Element back to just Embedding the Youtube video?

Hi Roger,

To better assist you with your issue, kindly provide us access to your site so that we can check your previous element settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works


Here is my secure note

Hey @rogermedia,

You said you’re using the Youtube Embed method but after checking the page you have not changed, your setup is you inserted the Youtube URL in a Video Player element. That is not embedding. Even if that might have worked in the past, it’s not guaranteed to work continuously because the setup is incorrect.


I’m sorry to say that your setup from the beginning is incorrect. The Video Player element will only work for self-hosted videos or direct to video URLs like That is what the label, VIDEO SRC URL, says.

I understand this is tedious and frustrating but, there is no way to convert your current setup to the Embedded Video Type. You would really need to convert all your video setup manually to use either the Video Element (Embed Type). Or, use the Classic Embedded Video Element.


If using the Video element (you already know this but I’m just confirming), you need to select the Embed Video Type.


That’s the same setup if you’ll use the Classic Embedded Video Element.


If you mean that you’re using the Classic Embedded Video element then all of the sudden it changed to the Classic Video Player element, that is impossible and there’s no such change in our theme for that.

Hope that explains it and thank you for understanding.

Thank you for taking a look and for the explanation.
Is there a SQL search I can run for the non-embedded element to more quickly identify which pages using it? I suspect there will be more than 100 to update and anything will help speed up the process.

Hi @rogermedia,

Regretfully, there’s no option to use an SQL to speed up the process. You really need to convert everything manually.

Hope that helps and thank you for understanding.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.