X-theme pot file errors

Hi, with the latests versions of x-theme I’m not able anymore to translate in my language with poedit.

If I try to create a translation poedit gives me a fatal error. It says there are some duplicates and I can’t go on.

Please, help me. I have tried some solutions found in the forum asrename on local the x.pot, but for me that doesn’t work. Also, I have tried to use an old translation of x-theme, but nothig, doesn’t work.


@krealiners Try Loco Translate Plugin and Translate the Theme Online from Dashoboard. Works with 1.2.7

Hi, thank you for the suggestion. I know well Loco, but I don’t want to use a plugin when I can simply use a pot file, which is made for translation purposes.

Hi there,

Thanks for writing in! I’m not sure about your error. It seems that the error is coming from your Poedit software.

Please follow our guide here (https://theme.co/apex/forum/t/setup-translation/61).


Hi, I have already follow your translation guide. I have tried to reinstall poedit, but nothings changed, the same error appears when I open x.pot file.

Can you make a check please?

Hi There,

It seems that you’re experiencing an issue related to Poedit software. Make sure to download the latest version and install it.

Also please try searching this error on a search engine, so that you will be able to find more information.


Hi, I have already installed the latest version of poedit. Actually, I have already the 2.0.4 because I have activated the automatic updates. So, I have unistalled it and then reintall Poedit, downloading from site prod. This error remains.

I’ve inspect about the error POedit shows and I’ve found the message definition duplicated is refer to this part of the pot file:

#: _dev/local.php:11
msgctxt “post type general name”
msgid “Things”
msgstr “”

#: _dev/local.php:12
msgctxt “post type singular name”
msgid “Thing”
msgstr “”

#: _dev/local.php:13
msgctxt “admin menu”
msgid “Things”
msgstr “”

#: _dev/local.php:14
msgctxt “add new on admin bar”
msgid “Thing”
msgstr “”

In fact, there’s two different element that share the same definition, i.e. “Thing” and “Things”.

Do you know anything about this? Can I change the definition in something else?


These are the two errors I receive. I post it in english, so you can undestand well what is happening.

When I open the x.pot I receive this alert:

Then, when i try to generate a new translation, poedit shows this error:

1 Like

Ok, it was enough save the pot file after alert and then I’m able to generate a new tranlation.

Thank you anyway


Glad you were able to resolve it :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.