X Theme - Cornerstone spinning wheel

I updated WP to 5.6, X theme to 8.0.11 and Cornerstone to 5.0.11.

i’m unable to edit my pages in Cornerstone as I get a spinning wheel.

I’ve disabled all plugins as well as Cloudflare.

Can you assist?

I just downgraded WP to 5.4.4 and I’m still unable to edit the page in cornerstone. Spinning wheel.

I decided to restore from a backup and rolled back to X Theme 7.2.3 and Cornerstone 4.2.3. Still have no plugins activated and am still having no luck to be able to edit my page home page.

Hmmmm… Please help . Thanks

Hello @nickpapp33.

Thanks for writing to us.

It seems that there might be an issue of plugin conflict.

I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing For Theme Related Issue
  2. Testing For Plugin Conflict
  3. Theme Update
  4. Child Theme
  5. Css/Js Customization
  6. Increasing Php Memory Limit
  7. Disabling Cache
  8. Disabling Cdn
  9. Permalinks
  10. Version Compatibility

If none of those work, It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • FTP Details

You can find the Secure Note button at the bottom of your posts


I tried everything and still had no luck. Couldn’t check this because of the spinning wheel problem.

  • Go to X/Pro > Theme Options > CSS and remove the CSS code there and check if the problem persists.
  • Go to X/Pro > Theme Options > JS and remove the Javascript code there and check if the problem persists.

I also wasn’t able to edit the page in Wordpress.

However, I was able to fix this. After adding the Classic Editor plugin, I’m now able to edit the page in Wordpress…but still have the spinning wheel when trying to Edit with Cornerstone.

Can you check it again on your end?

If that doesn’t work, I will set up a staging site for you.

Hello Nicholas,

Thanks for providing the information. We could not check your site because we have encountered an error.
See the secure note.

And also, it seems that you do not have a valid SSL certificate. Kindly install Really Simple SSL plugin to correct your issue.

Best Regards.

Please go ahead and give it another try. It should be accessible now. Thanks

Hi Nicholas,

It seems that you have a corrupted WordPress files because when I tried to switch the theme to default WordPress theme, there are still so many errors in the console log pointing to 404 error.

I suggest that you delete all your WordPress files in your staging environment folder except for the wp-content folder and wp-config.php files. Then download the new files from WordPress and copy all the files to your staging environment folder except for the wp-content folder from the newly downloaded WordPress files. In that way, you will have updated files that might able to help you fix the issue you are facing on.

Hope that helps,

Thank you.

Thanks for the update.

I copied new Wordpress files (except for wp-content folder and wp-config.php file) and went into my WP Dashboard.

Can you please go in and see if you can get Cornerstone to load for me. I got this error when attempting to edit my homepage in Cornerstone.

Not Found

The requested URL was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Thanks so much.


I researched this problem in the forum and used this to fix this problem

Go to Settings > Permalinks and select “Post Name”.

I seem to be able to edit the page, and will give it a try now.

Hi Nicholas,

To further help you with your issue in your live website. Please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Thanks so much. Please see most recent secure note for logon details

Hello @nickpapp33,

The given credentials are not working, please recheck and send us again.


Please see updated info in secure note

Hello Nicholas,

We cannot open your site. A warning message is displayed.

See the secure note.


Please use Google Chrome to access the site. Edge and Explorer are having some issues that require me to edit the site, which is what I can’t do until we solve these issues.

Thanks so much.

Hello Nicholas,

Your server do not load any CSS or JS file resources. You may need to contact your hosting provider and ask them about the Error 403 happening in your site at the moment.

Refused to apply style from '<URL>' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.
Failed to load resource: the server responded with a status of 403 ()
Failed to load resource: the server responded with a status of 403 ()
Failed to load resource: the server responded with a status of 403 ()
Failed to load resource: the server responded with a status of 403 ()
Failed to load resource: the server responded with a status of 403 ()

Please let us know how it goes.

Thanks so much for using a different browser to help me troubleshoot

Can you please scroll up and review the entire conversation because this has been a multi step process.

I created a staging site and was able to fix the problem by deleting WP core files and replacing them with newly downloaded files.

When I pushed staging to live I still have the same problem on the live site.

Do I now also have to delete and replace the core WP files on the live site? I thought pushing to live from staging would take care of that.

Thanks in advance for taking some extra time to scroll up and review everything before responding.

It might also be good to check with some of the other techs that are replying to me as it seems different people taking on this case are not aware of what has already been happening as we come to a solution.

Thanks again. I really appreciate your help.

Hey Nicholas,

Firstly, please understand that our builder is only affected by your web host’s incorrect server setup. We do not provide support for web hosting issues and WordPress in general.

Please contact your web host as they have the answer to why it worked on staging but didn’t on the live server. Show them the previous screenshot provided by my colleague.

Once those 404 errors are resolved and the builder issue persists, we can continue our investigation.

Thank you for understanding.

Ok. You should be able to check it now.

This is what the server company said. They are very nice.

Thank you for contacting us today!

I am very sorry about the trouble that you are experiencing with your live site and I am more than happy to help you with that.

There was a .htaccess file with deny rule under the wp-includes folder of the live website. I have now removed that and the live site is working as same as the staging site now.