X-Pro not launching

When I try to launch X Pro from the side bar on the dashboard I am presented with the screen with the various options, when I click on either headers or footers, the blue bar goes across the top of the screen to the right, but I remain on the launch screen.

I have done all the usual such as clearing caches, disabling plugins etc. all to no avail

Getting the following

Rejecting AJAX promise {invalid_user: true, message: "nonce verification failed."}
handleResponse @ cs.js?ver=2.1.7:56152
normalizejqXHR @ cs.js?ver=2.1.7:56224
run @ cs-vendor.js?ver=2.1.7:639
run @ cs-vendor.js?ver=2.1.7:24068
(anonymous) @ cs.js?ver=2.1.7:56232
(anonymous) @ jquery.js?ver=1.12.4:2
i @ jquery.js?ver=1.12.4:2
fireWith @ jquery.js?ver=1.12.4:2
y @ jquery.js?ver=1.12.4:4
c @ jquery.js?ver=1.12.4:4
XMLHttpRequest.send (async)
send @ jquery.js?ver=1.12.4:4
ajax @ jquery.js?ver=1.12.4:4
submitRequest @ cs.js?ver=2.1.7:56231
(anonymous) @ cs.js?ver=2.1.7:56056
initializePromise @ cs-vendor.js?ver=2.1.7:51311
Promise @ cs-vendor.js?ver=2.1.7:52906
promise @ cs.js?ver=2.1.7:56055
requestBatch @ cs.js?ver=2.1.7:56079
run @ cs-vendor.js?ver=2.1.7:639
(anonymous) @ cs-vendor.js?ver=2.1.7:941
setTimeout (async)
debounce @ cs-vendor.js?ver=2.1.7:939
run.debounce @ cs-vendor.js?ver=2.1.7:24619
(anonymous) @ cs.js?ver=2.1.7:56032
initializePromise @ cs-vendor.js?ver=2.1.7:51311
Promise @ cs-vendor.js?ver=2.1.7:52906
request @ cs.js?ver=2.1.7:56021
modelRequest @ cs.js?ver=2.1.7:56015
(anonymous) @ cs.js?ver=2.1.7:49
initializePromise @ cs-vendor.js?ver=2.1.7:51311
Promise @ cs-vendor.js?ver=2.1.7:52906
_request @ cs.js?ver=2.1.7:48
findRecord @ cs.js?ver=2.1.7:31
_find @ cs-vendor.js?ver=2.1.7:149098
fetchRecord @ cs-vendor.js?ver=2.1.7:147271
_fetchRecord @ cs-vendor.js?ver=2.1.7:147332
_flushPendingFetchForType @ cs-vendor.js?ver=2.1.7:147378
cb @ cs-vendor.js?ver=2.1.7:21274
forEach @ cs-vendor.js?ver=2.1.7:21079
forEach @ cs-vendor.js?ver=2.1.7:21282
flushAllPendingFetches @ cs-vendor.js?ver=2.1.7:147321
invoke @ cs-vendor.js?ver=2.1.7:1335
flush @ cs-vendor.js?ver=2.1.7:1399
flush @ cs-vendor.js?ver=2.1.7:1207
end @ cs-vendor.js?ver=2.1.7:521
run @ cs-vendor.js?ver=2.1.7:643
join @ cs-vendor.js?ver=2.1.7:663
run.join @ cs-vendor.js?ver=2.1.7:24110
(anonymous) @ cs-vendor.js?ver=2.1.7:44204
flaggedInstrument @ cs-vendor.js?ver=2.1.7:20504
handleEvent @ cs-vendor.js?ver=2.1.7:44203
exports.default._emberMetalMixin.Mixin.create._Mixin$create.handleEvent @ cs-vendor.js?ver=2.1.7:43264
_bubbleEvent @ cs-vendor.js?ver=2.1.7:43743
(anonymous) @ cs-vendor.js?ver=2.1.7:43665
dispatch @ jquery.js?ver=1.12.4:3
r.handle @ jquery.js?ver=1.12.4:3
cs.js?ver=2.1.7:339 Transition Error {invalid_user: true, message: "nonce verification failed."} Transition {state: TransitionState, intent: C, router: Router, data: {…}, resolvedModels: {…}, …}

Hello There,

Could you could try testing for a plugin conflict? You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If nothing else works out, would you mind providing us some access to your dashboard so that we can take a closer look?

Please let us know how it goes.

Message sent

Hi There,

I Cannot see your credentials here, please could you add it in a secure note on this thread?

Thank you

I did send it in a secure reply (or made a mistake doing that) so exactly how?

Hi there,

I’m able to reproduce the issue on your site, but can’t figure out what’s causing this. The error says it’s invalid user, and because of that, the nonces are affected. Could you try this workaround?


Tried that and no difference

Hi there,

Would you mind providing your FTP login credentials? Maybe I can find something there. And for the meantime, please clone your site in staging, I may try some re-installation there, and provide its FTP credentials too.


I am not sure what you mean by “Clone your site in Staging”

Secondly I notice a new Administrator account has been created on the installation

Hi There,

Please clarify what do you mean “new Administrator account has been created on the installation” we do not create a new account on site unless its part of the issue.

I notice that you have a couple of Autoptimizer plugin, a caching plugin, and security plugins, would you mind clearing those plugins for any cache and deactivate it for a while, while we troubleshoot this issue.

Please redo the plugin test, while the caching/optimizer plugins are cleared and deactivated.

Also, please try switching to parent theme as I am seeing a customization on your child theme that can be caused by this issue.


Yes, re-run all the tests with plugins deactivated and still not working

Hey @dpe,

Your server is empty. Please give us the correct FTP credentials.

Please also clear all caches and keep optimization plugins deactivated like Autoptimize and your caching plugin while we’re troubleshooting.


FTP account should now work OK

Hey @dpe,

Pro works in your site now. Here’s what I did:

  1. I discovered you’ve used W3 Total Cache. When you uninstall it, it leaves code in wp-config.php and .htaccess. I commented out the code in your wp-config.

  1. I then reset your htaccess by renaming .htaccess to .htaccess.bak and then updated your permalinks.

I also deactivated WP Super Cache and one of your security plugins while I was troubleshooting. You can enable them back but if the problem returns when they are enabled, you need to remove them.


Many thanks, that all appears to be working now

Thanks for letting us know.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.