Wrong image URLs within Cornerstone

Hi, I’m having trouble with wrong image URLs after I migrated the site using WP Migrate DB Pro. I used a temporary url while I migrated the site and then switched to the right url. I have used “Better Search Replace” and deleted transient data in database. Nothing seems to work. On the front, the URLs are correct but when I go into edit mode in Cornerstone, all the image URLs are wrong. Have searched the forum and tried the solutions offered by the support but nothing have helped. Need assistance.

Hi @Frosting,
Thanks for reaching out.

There are a few possible reasons for the issue and can help after having the exact errors.
Please add the below-given code into your wp-config.php for debug setup, and the error logged into the file name debug.log inside the wp-content folder.
You can let us know if you find any error that is related to our theme or theme bundled plugins. We can do further investigation based on that.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

Please find the video will help you to edit wp-config.php and add the above code: https://www.youtube.com/watch?v=3SDPTafEM8o
If you discover that an issue is coming from custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.

If none of these helps, please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Admin URL
– Specific Page URL, where you are having the issue.
– WordPress Admin username / password
– FTP/CPanel access

To create a secure note, click the key icon underneath any of your posts.


Hi, thanks for your reply. I migrated the site again, but this time manually and did not use a temporary url. The site work fine now but I’m getting mixed content in the header. I use images in thet header (using the PRO header) and all of these are using http. I have done a search and replace in the database using wp-cli and also looked for expired transient data but not found anything. If a edit the headers (I’m using a few) and replaces the images manually, the images gets the right url, https. But it’s kind of a daunting task… Is there another way of replacing the wrong urls?

Hi @Frosting,

In case you are using wp-cli, most of the search URLs are replaced by the replace URL, but sometimes not able to replace the URLs if that is inside the content.
If you want to update those URLs using any plugins, you can get help from this given URL: https://www.wpbeginner.com/plugins/how-to-update-urls-when-moving-your-wordpress-site/
You can also get some more help from the below-given video:

Hope it helps.

Hi, that plugin seems outdated. I used the plugin “Better Search Replace” which i normally use and works great but it doesn’t seem to find the url’s needed. Do you have any other suggestions or do I have to change the URLs manually?

Hi @Frosting,

To better help with your concern, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password
  • Cpanel Access

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hey @Frosting,

I logged in to your site and I don’t see any mixed content error and broken images and all images are pointing to your domain.


Maybe I’m missing something so please also detail what’s broken and also provide screenshots.


Hey, thats strange? When I go to a subpage, for example /produkter/orbot, I’m getting mixed content from the header that loads images from http instead of https. The frontpage is also showing mixed content.

Hello @Frosting,

To get this issue resolved, please install Search and Replace plugin. You will have to search for the image url using the http:// and will have to replace it with the https://.

See the secure note.

Kindly let us know how it goes.

Hello, thanks for your reply. That sorted the URL’s on the frontpage, but not on subpages. There is still images loaded from http in the header, rather then https. It strange because I did a search and replace before, but not with the ending /wp-content/uploads/.

Hey @Frosting,

Thank you for clarifying that the issue is in the sub pages.

Sometimes, you need to try escaping the slashes when doing a search and replace. I tried that to show you that it works and now there’s no more mixed content warnings in the console.

Please note that because you’re using a caching plugin, the old cached page might be loaded by your server and that is beyond our control. You need to clear your cache or contact your web host to clear all caches.

Hope that helps.

Hallelujah! This problem has been bugging me for quite some time, big thanks for your help and solution. Did not now that you’d have to escape the slashes when doing a search and replace.

Hi @Frosting,

Great that it resolved now.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.