WooCommerce products not showing despite succesful import

Hello support team,

I am currently in the process of building a webshop, and I am encountering some problems with the WooCommerce import functionality using the X theme.
When creating a new product manually everything works fine, but importing products through CSV will not work. The import is succesful each time, and WooCommerce states that it has imported the products, which tells me the CSV file is not the problem. However, when I want to view the products in my shop they are not showing, nor do they appear in the list of products on the back-end of my website. It is as though nothing has been imported even though WooCommerce says the import was succesful.

I have tried to deactivate all active plugins except for woocommerce to make it work, but that did not solve the problem. The only thing I can think of is to deactive X theme, but perhaps you guys know a better solution.

I hope you can help me.

Thank you in advance.

Hello @EastwoodWatersportsWebmaster,

Thanks for writing to us

To import the WooCommerce product from CSV you need to go to the Tools --->Import--->WooCommerce products (CSV)-->Run Importer.

In case if it is not working for you please make sure your CSV file is correct. You may check the dummy date CSV file that is been given by WooCommerce.

You would get the sample data file on this location wp-content\plugins\woocommerce\sample-data

Filename: sample_products.csv

Hope it helps

Hello @prakash_s,

Thanks for your reply. The problem has been solved, thank you!

You are most welcome.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.