Woocommerce doesn't redirect to thank you page after order completion

Hi there,

I’ve noticed that since the latest WooCommerce and Wordpress updates, WooCommerce doesn’t automatically redirect to the “Thank you” page confirming the customer’s new order.

The customer clicks on “place order” button, but the checkout page just reloads. The order actually completes okay on the back end and shows up on the admin panel as well as the payment processor completes the payment. But the customer doesn’t know that since they are not directed to the Thank you page and they do not get their order confirmation email.

Is this an issue with the theme needing to update it’s WooCommerce templates?

Let me know what other information (error logs, etc.) you might need.


Hello @Armkk

Thanks for writing to us.

There might be a few different reasons for this issue, I would suggest you troubleshoot with a few of the common issues before we investigate the settings.

  1. Testing for Plugin Conflict
  2. Child Theme Issue
  3. CSS/JS Customization
  4. Disabling Cache
  5. Version compatibility

If none of these work for you, I would suggest you to copy your live site to a staging server so we could troubleshoot freely without breaking your live site. Please share your details in a secure note. Please provide the following details

  • Staging WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts



Thank you for the suggestions. Since it’s a live site, I am having a clone made for testing purposes. I wanted to see if this was a known issue with the theme. I will report back here after testing and take it from there.

Hello @Armkk

This is not an issue of the theme. Maybe there is something else cause for this. Let us know if the issue still exists after testing.


Happy to report that the issue has been resolved by doing a re-install of WordPress itself.

We’re not quite sure what was causing the issue. But it may have been due to corrupt database or installation that could have been caused by the latest WordPress update.

Hi @Armkk,

Glad to know that the issue has been solved.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.