Weird bug in conditionals? Or am i missing something

Hi there! I am using conditionals to show whether certain sections show up on a user page or not.

In this particular use case, users that subscribe are automatically logged in and then land on their ‘my account’ page. If this is their very first visit to that page, they should first create a secret password.

Once they do that (via gravity forms) they get a tag ‘has_set_password’ added in their activecampaign data. Once they have set their password, that gravity form should no longer appear on that page.

The page that I will link to in the private section below has the following shortcode for that conditional, to demonstrate that the logic for it is working properly:
[mbr_is_conditional id=‘3522’]
Condition 3522 (has tag ‘has_set_password’) is met: Your userdata has this tag, therefore, it renders ‘true’
Condition 3522 (has tag ‘has_set_password’) is not met. Your userdata shows you do NOT have this tag, therefore it renders ‘false’

I want to use the exact same conditional for the section, like so:
So… this section should only show up when the condition renders NOT true, i.e. false.

Interestingly, I can get this to work the way I want it to if I REVERSE the logic??? So when i want the section to appear when this conditional renders TRUE (like in this screenshot) above, when I set it the condition to false

So to demonstrate this, I have created another section exactly like it, but with the condition REVERSED (and a red background on the section, to show that it is the reversed one). There, the condition is set like so:
You can try this out via the link that I will share in the private note. I would recommend that you then set a password yourself. Because then you will land on the exact same page, but with the user data changed.

Hello Tristan,

Thank you for the detailed post information. We would love to check out your page setup and element settings. Please provide us access to the site so we can check the conditions in your my account page. You can create a secure note in your next reply with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works


Thanks, I could not add a new secure note, but have edited the earlier note to include admin user access details and confirmation that you can make changes.

Hello Tristan,

You are using the element condition along with your Conditionals incorrectly. Please be advised that the Conditionals were created as a custom post type.

Using the element condition as shown below, will only be true or false when the page being displayed is the specific single conditionals custom post type. Please use the page (specific) or posts (specific) for better understanding.

You cannot use the dynamic content or the conditions for what you have in mind because when you created the Conditionals, it should be used as a shortcode like this:

The correct way of using this is by creating two global blocks in Cornerstone > Global Blocks. You will have to create your element or a section to display in a global block. On the “my account” page, you will have to insert a Raw Content element and insert the shortcode along with the global block codes. Takes this as an example:

[mbr_is_conditional id='3534']
    [cs_gb name="has_not_set_password"]
    [cs_gb name="has_set_password"]

Hope this explains your issue briefly.


FYI: I have also tried to see if I could get it working with the Pro condition set to ‘number’ or ’ string’ and then have the shortcode [mbr_is_conditional id=‘3522’]1[ELSE_is_conditional]0[/mbr_is_conditional] render either 1/0 or true / false, but that doesn’t work either.

So i will now go with your suggested solution, by using raw content for the shortcode and use global blocks instead.


Hi Tristan,

Please let us know how it works for you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.