W3c validator errors for x-widgetbar

Hello, I am running WP 4.9.5 with X 6.0.4 Integrity theme. My site is https://www.bellafsm.com

I am receiving w3c validator errors I can not fix that appear to be related to x-widget-bar.

Here is error when header widget is activated in customization section:

If I deactivate header widget this is error:

Here are three other errors. One also appears to be related to x-widgetbar:

I use W3TC and always clear cache.

Please advise.

Best regards

Hi @jnlinn,

Thanks for writing in.

I could not be able to know what causes the problem base on the error you shared. Would you mind sharing us your admin credentials.

Don’t forget to set it in a secure note.

I will share below a link that is similar to your concern.

Hope it helps.


Hello Nico, I just added secure note with my login credentials.

I looked at the link you provided but unfortunately it does not help.

I have searched this forum and see a few references to “x_legacy_header_widget_areas” and tried adding some of the suggested code to my functions.php file but did not help either.

This error shows on every page and post on my website.

Please advise.

Thank you.

Hello @jnlinn,

Thanks for asking. :slight_smile:

There are couple of errors I see on W3 Validator.

  1. The type attribute is unnecessary for JavaScript resources: For a possible fix, please take a look at following thread. https://wordpress.stackexchange.com/a/292663
  2. The other error messages that’s showing up on the validator is quite odd. CSS parsing error is related with Content Dock and following code.
.x-content-dock a:not(.x-btn):not(.x-recent-posts a){color:#2630eb !important}

I checked to see if you have added some custom code in theme options panel and theme css file. But I don’t see any code related with content dock. However, I see something that’s quite odd in extensions page of X Theme. Over there I see that content dock is not installed but when looking under X Menu and Plugins page content dock is installed. https://cl.ly/1Y0s2v2p0L3m

I think there might be some issues with installation being corrupted. In that regards, can you please try to reinstall X Theme, Cornerstone and Content Dock plugin and see if doing so resolves the problem you are seeing.

Let us know how it goes.


Hi Prasant,

Thank you for the suggestion. I will try to reinstall X Theme, Cornerstone, and Content Dock. I will back up site beforehand.

What is the cleanest/best way to reinstall these items, especially since W3TC is running.

Best regards.

Hi @jnlinn,

Yes, that is right. Backup before re installation.

If you wish to start over again with fresh install. Then it will be best if you will install new wordpress too, then just follow this https://theme.co/apex/forum/t/setup-theme-installation/54 again

Some hosting provider provide automatic installation and removal of wordpress, you may use their hosting feature.

Or you can create just new wordpress install in a different directory using your hosting tools like fantastico for cpanel, app manager for goddady, and etc.

Or you can manually install it http://codex.wordpress.org/Installing_WordPress

Again, installing X theme is just the same as this https://theme.co/apex/forum/t/setup-theme-installation/54

Hope it helps.

Let us know how it goes.



I do not want to reinstall Wordpress. I was asking best way to reinstall X theme, cornerstone, and content dock. I do not want to do this if not needed. I do not see anywhere in Wordpress Admin to “reinstall” or “delete” themes.

I found answer to script “type” validation warning which will be fixed in Wordpress 5.0. Here is thread: https://core.trac.wordpress.org/ticket/42804

I was able to deactivate and delete Content Dock and reinstall. Content Dock now appears under X menu. However, validation errors still appear. If I disable Content Dock the two validation errors disappear. Possibly bug in plugin?

Also, still have two validation errors for “Error: Element a is missing one or more of the following attributes: role.”

Please advise.

Thank you

Hello There,

To re install Cornerstone, simply deactivate the plugin and delete it in your plugins section. Once you visit X > Validation, Cornerstone will be automatically installed.

To re install X theme, you will have to do it manually. Please check out Manual Update section from this knowledge base article: https://theme.co/apex/forum/t/setup-updating-your-themes-and-plugins/62

The errors could potentially be a bug in the X Content Dock plugin. I’ve submitted this to our issue tracker so the developers will be made aware of it.

Best Regards.


I was able to manually reinstall X theme and Cornerstone. Unfortunately the validation errors still exist…

I also noticed a new issue with Content Dock on the main Blog index page. The content deck always displays, and displays off the bottom of the page. Here is an image:

To summarize, it appears there are three issues:

  1. Content Dock display issue on Blog page
  2. Contect Dock css validation errors
  3. x-widgetbar missing “role” attribute validation error

Please advise.

Thank you


I am editing this response since I just found other issues.

The Yoast generated page-sitemap recently stopped including images for my home page. Here is image:

I deactivated then reactivated sitemaps in Yoast settings but problem not fixed. Then I tried editing home page in Cornerstone and replacing “classic” image elements with new image elements (using same image url). Did not fix sitemap. Also, now I see Yoast does not recognize images in seo analysis. Here is image:

Ironically, now Ryte and other seo tools see image height and width property but Yoast can not see images at all. I do not know what is accurate.

Also, I tried to add new section on home page in Cornerstone and it will not allow me to add elements.

To summarize new issues:

  1. Yoast page-sitemap not including images for homepage (if I update subpages images will most likely will also be removed)
  2. Can not add sections to home page in Cornerstone
  3. If “classic” image element used, Yoast sees image but other seo tools do not see height and width property. If new image element used then Yoast does not see images and other seo tools see height and width.

Please advise. This all seems like a mess :frowning:

Best regards

Hi there,

Would you please separate all the cases in different threads so we can focus on each one by one?

As this thread was originally added for the Validation error I will follow up with that:

We already added this to our issue tracker, the auto generated CSS of the Content Dock plugin seems to create a problematic CSS code when it comes to the valid syntax.

For the Visual problem of the Content Dock please open up a separate thread and give us the details to follow up. We do not have the same problem in our local installation so it must be something on your side. Make sure that you have the latest version of the Content Dock plugin installed.

There is a problem with the Yoast content analyzer compatibility with our theme as we save the content of the V2 elements in the Meta Options table of the database which Yoast does not check. We already added this to the issue tracker and this will be fixes in the upcoming release of the theme.

I added the lack of role attribute validation problem to our issue tracker and we will follow up the case. Please stay tuned for the upcoming releases.

The problem of adding a section to the homepage needs to be checked in the separate thread.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.