Version 4.07 installed 2-3 years ago


My (ex)business partner setup a WP website using your X theme 2-3 years ago.

I have finally got around to look at this website, and I it is using ver 4.07 and it doesn’t look like he (the ex-business partner) entered the rego details.

So - I just bought the X theme.

Now - I need to register it (it says to Get an API Key), which is why O’ve just registered with this system.

Also - can you tell me if I can upgrade from ver 4 to ver 6?


Hi Rick,

Thanks for writing in!

You can get your license key by visiting the license page of apex dashboard.

There you will find your license key.

You can update your theme to latest version, before that you have to validate your site.
Please check validation guide.

and Update best practice,

Hope this helps!

Thanks - but I have additional problems

First - my ‘Apex Dashboard’ doesn’t look like this screenshot. I get a dropdown menu next to my account icon - and select ‘Licenses’ ( where I have entered my themeforest ‘Item Purchase Code:’

Then, back on my WP dashboard - When trying to validate, I get the error “Could not establish connection. Please ensure your firewall is not blocking requests to” NOTE, it asks for an ‘API Key’

I am on an old server… I had moved this site to a new server (getting ready to install https, etc) but the move didn’t work - I had all sorts of issues with the website (couldn’t upload images, update plugins, menu links didnt work, etc).

So, I’ve re-delegated it back to the old server, the site ‘works’ - and I’ve started the process of updating everything before moving it to the new server again

And - as noted, this theme was purchased 2-3 years ago - but I do not have access to the account that made the purchase so I bought it again.


Hey Rick,

Basanta posted our staff interface. We’re sorry about that.

I checked your licenses page ( and I see you have not assigned your domain yet. Please see Product Validation posted by Basanta previously.

If the issue persists, please try the solutions suggested in our Troubleshooting Validation Connection Issues:


Hi Christian

I have tried all this -

Please answer this question

Does this validation process require SSL?

As this is my problem - my current host doesn’t have SSL - my new host does, but the website using the X theme doesn’t work on the new host.

So - I hope to solve the problem by updating everything on the old ( NON SSL) server - then move to the new server.

If this is not possible, please let me know and I will move the site as is and try to fix the broken site from the new server.


Hey Rick,

No, validation does not require SSL. Would you mind giving us WordPress Admin access to your old and new hosts so we could compare the working site with the site with issue. Please post the credentials in a secure note.


Thanks Christian

I didn’t see the secure note at first -

This is the ‘live’ website back on my old server.

When moved (via Cpanel) to the new server - I couldn’t see media files, copy up media files or update plugins. Host said it was the WP settings - tried to fix it. Then the menu links stopped working - so I changed the nameservers back to the old server.


Hi Rick,

Thanks for the details!
I am able to login to your site and then trying to validate it shows an error, which is related to server connection.

Connection refused generally your site is unable to contact our server. Is your site behind a security firewall?

Please get in touch with you hosting provider and make sure that:

-Ensure my site can reach this domain:
-Ensure cURL is working, and allow_url_fopen is enabled.
-Ensure PHP is configured with the latest CA Root Certificates.


Hi Basanta

Well, it took my host a week to get back to me

They say “We have assisted to enable the allow_url_fopen”

They said nothing about reaching the domain or the PHO configuration


I really don’t know what else I can do (clearly there is a reason I am leaving this host)

If I move this website to my new server - it doesn’t work (cannot copy up images or see the media files, new host said it is configured wrong, tried to fix and the menu stopped working!)

So - went back to my old server with a plan to update everything, and try moving it again.

But - that too is impossible!

Can you provide me with any path to a solution - or should I just scrap this website and start over with a different theme?


NOTE Also - the new host said the "upload path for your media in your database was not set at all. " which is why the website did not work on the new server (when they tried to fix, the menus stopped working)???

Hi There,

I could see that you’re using the WordPress version 4.3.17:

Please update the WordPress core to the version 4.9.8. Here is the update guide:

After updating your WordPress core to the latest version, please try manually updating your X theme and Cornerstone plugin. Manually updating theme & plugin guide, you can find on this link:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.