Validation issue for updates

In regards to the sharing icons problem. The sharing icons are showing up if I use Chrome but not in Safari. I have tried clearing the cache and restarting the browser but they still do not show up.

This seems strange as they previously worked in Safari and I would like to get them working in all browsers again.

Hey Mark,

Your server is empty. Please give us the correct access.


I am very sorry please try again with the details above, it should now take you to the right folder.

Hi Mark,

I did some tests and I could not find the reason why the automatic update is not working. I still think this is a problem of the hosting service not being able to access Themeco servers.

You can contact your hosting service provider and ask them to make sure that there is a cURL access to Themeco servers as mentioned in the troubleshooting section of the article below:

You will need to update the theme manually on your live server manually. I uploaded the zip file of the latest version in wp-content/themes/ folder. Please use the File Manager panel of your hosting service to unzip that file. Before the unzipping, you need to rename the x folder and make it for example x-backup.

After that you will need to delete the Cornerstone plugin from the WordPress Admin, and go to X > Validation and wait for a few seconds and the new version of the plugin will be installed.

The current version of the theme is 6.2.3 and that is why the theme forces the version 3.2.3 id the Cornerstone. As the version, 3.2.4 will not compatible with the version of the theme.

Thank you.

I have been in conversation with SG support and they can’t seem to find the problem. They have asked me to ask you these questions;

  • Check with the support team the exact CURL request that the theme is making so we can execute it from the server’s Shell.

  • Request more information to be provided about the blocked request - if there is a such, our server will return a specific Status code that should be logged in the access logs of the remote server.

Hey Mark,

Regretfully, I could not find what’s causing this either. I’ve seen this line in your WP Config define('AUTOMATIC_UPDATER_DISABLED', true);. I’m not sure if that affects automatic updates. I’m afraid to touch your setup and also your htaccess as it has some https config in there so I might break your site. Would you mind contacting SiteGround if it’s possible to remove that and restore WordPress’ default htaccess setup? If that doesn’t work, I’ll forward the information SiteGround has requested to the appropriate person.

If you could do a manual update in your live site, that would be the quickest method to update now. The fastest way is to login to your cPanel and delete the X parent folder then upload the latest installable zip file in your themes folder and extract it using the cPanel unzip function.


Hi Christian,

Siteground have just managed to get cornerstone updated, but for some reason X is still stuck on 6.2.3 and not showing in the updates. I will try doing the manual update of X this evening and hope that this problem goes away for future updates.

SG just compared the .htaccess on the staging server to the one on the live site and they are both the same. The staging site is working as it should though. I am not going to try going back to the standard one as I think it will break wordfence firewall.

I am also unsure as to what the define(‘AUTOMATIC_UPDATER_DISABLED’, true); bit is in the WP Config. Do you think it is safe to just remove that?

Thanks for your help.



I have just manually updated X on the live site and everything appears to be working and on the latest versions now. I guess I will know if this problem has been resolved when the next auto updates happen. I actually switched to another theme, deleted the old X and uploaded the new version and switched back to it.

I have noticed one problem that is confusing. On the collection pages my sharing links are not showing up in Safari anymore, but they are still showing in other browsers.

Safari -

Chrome -

This used to work in both browsers prior to this update. Is there anything that can be done to sort this?

Kind regards,


On investigating this it appears this is just about Wordpress updates and nothing to do with the plugins or themes. It is added to WP_Config on the SG server because automatic updates are carried out via SG directly. So I think it is safe to say that isn’t the issue.

Hi Mark,

I couldn’t replicate the sharing icons issue on Safari, please check these two screenshots for the live site and staging one:

Could you please clear your browser cache and recheck this issue? also -if possible- you can try Safari browser on different devices.


Hi Alaa,

Yes I have cleared my cache several times since this happened and it still doesn’t show in Safari on my Mac Pro. I am just checking the live site.

I have just tried it using Safari on my iPhone and it works fine on there. I will try on my iMac at my studio tomorrow.

Here is a screen cap of Safari (Mac Pro) with the console open.

And here is the same for Chrome on my Mac Pro

I have just looked at a warning that has shown up in Wordfence security software. This is telling me that my DNS has changed.

This is the report it gives;

I also had a look at the Wordfence scan and saw a warning that my DNS had been changed. This I think could be the problem and it is not something I have done. Here is the Wordfence report on the DNS Change;

Old DNS Records:
New DNS Records: points to

Details: We have detected a change in the CNAME records of your DNS configuration for the domain A CNAME record is an alias that is used to point a domain name to another domain name. For example can point to which then points to an IP address of A change in your DNS records may indicate that a hacker has hacked into your DNS administration system and has pointed your email or website to their own server for malicious purposes. It could also indicate that your domain has expired. If you made this change yourself you can mark it ‘resolved’ and safely ignore it.

I wonder if this is the root of the problem. I am asking my host what is going on.


Another support here, I am sorry but I am not sure about that. I checked on safari in Mac and could not replicate the issue as well.

See screenshot

This could be a browser issue, can you try reinstalling your browser and see if that works.


Thanks on checking my other computer at work everything works fine in Safari, so I guess this is a local problem on that machine. I will try an OSX reinstall.

I am still having problems with the cornerstone updates not happening because it is saying that my theme isn’t verified. I have just found out that my DNS record was changed 5 days ago and am trying to work out if this could be the problem that is causing this issue.

Hi Christopher,

I have been looking at the link you supplied for trying to resolve this issue. I have tried the verbose error report by checking the URL

The response I get is a grey box telling me “Sorry, you are not allowed to access this page”

I have also posted to SG support a link to the page and asked them to check it.

I manually updated X to 6.2.4 but now still the latest cornerstone update says below it “Validate X to enable automatic updates.”

I am really unsure of what has caused this problem. This site has been doing automatic updates for years with no problem, I have numerous X sites on the SG servers and none other have issues. Even the staging copy of the site that does have the problem doesn’t have an issue.

Please, can someone help me to solve this as I can’t be always having to do manual updates on it.

I have just had the following reply from SG support and am still no closer to solving this mystery;

I checked the website via curl and it is fully working

antoniapopmicheva@Antonia-Popmicheva:~$ curl -I -X GET
HTTP/1.1 200 OK
Server: nginx
Date: Wed, 25 Jul 2018 11:56:17 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
X-Powered-By: PHP/7.0.31
X-Cache-Enabled: True
Link:; rel=“”,; rel=shortlink
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Set-Cookie: wpSGCacheBypass=0; expires=Wed, 25-Jul-2018 10:55:14 GMT; Max-Age=0; path=/
Set-Cookie: PHPSESSID=ccc77407eed812b6d1162127c81323ef; expires=Wed, 01-Aug-2018 11:55:14 GMT; Max-Age=604800; path=/
Host-Header: 192fc2e7e50945beb8231a492d6a8024
X-Proxy-Cache: HIT

I also enabled the allow_url_fopen function through the php.ini file. The SSL verification is also confirmed and there is no issue with it.

I also used the guide and run the checks using the “force-check” flag and adding &x-verbose=1 but no errors where shown. Please login to the dashboard and add this to the admin URL so it looks like this:

I also checked the server error logs and fixed the permissions to the files. There are no php_errorlogs as well.

On doing what she asked I just got a 404.

Hi @Pixel8r

I believe it could be a memcache issue, because I checked your phpinfo() and it seems that memcache is supported, however, if I go to (SG optimiser > SuperCacher Settings > Memcached Settings) and tried to enable it from there, it says:

That’s really weird, does that mean it’s enabled and stuck at this state? if I were you I would ask SiteGround to either purge memcached or make sure it’s disabled, then click on the “Check Now” link in (X > Validation).


I have passed that message onto SG support, I have Memcached turned off on the server currently anyway.

For a test I just deactivated the SG Optimiser plugin and went to check. Still the same X 6.2.4 says that it is validated, but go to the updates and Cornerstone upgrade says “Validate X to enable automatic updates.”

I expect this is some issue not concerning the plugins, as the staging copy of this site with the exact same plugins does not have an issue.

This has been going on for a long time now. :frowning:

The problem is that your Object Cache is not configured correctly. I installed the Transient Manger plugin which you can access at Tools > Transients. To clear the update cache manually you should be able to delete the update_themes transient. This will cause everything to check for new versions rather than using the cached versions.

If you try deleting that transient nothing happens. This means WordPress doesn’t have a working Object cache which could lead to all kinds of abnormal behavior. There’s a drop-in plugin for Memcached installed. Could you try removing that? Afterwards try deleting that transient again. Let us know how that goes.

I didn’t really understand what you are talking about so I posted your message to the SG support. Here is the response that I got from them. BTW this has not solved the problem and my live site is still stuck saying X is validated but Cornerstone is saying it needs validating to do updates. This problem has been going on for a week now and I have tried numerous things. Facts are the staging copy of the site is working fine, with exactly the same plugins and on the same server, but the live site keeps showing this problem.

I have cleaning the Memcached cache and also clear the transient records in the database. Please test again. If however, the issue is still present I will kindly ask to submit a new ticket and provide us with detailed step by step instruction on how to recreate the issue thus this one is getting quite long and confusing.

In order to have all correspondence in the same place, which will ease following the development of the issue and its resolution please submit a new ticket in the correct category and we will be happy to assist you to the best of my extent.

Your understanding on the matter is greatly appreciated!