Validate code not working


I have a problem validating my X Theme.
I had a little problem with my domain purchase and for a bit I was just under my ip. Now, my domain name is back and I am trying to validate the copy but it does nothing.

I copy and paste my code where it says this:

You’re almost finished!
Your license of X is not validated. Place your Envato purchase code or Themeco license to unlock automatic updates, access to support, and Extensions. Learn more about product validation or manage licenses directly in your Themeco account._

Now, when I press enter nothing happens.

Any help?

Hi There @landerolabarri

Thanks for writing in! Upon checking your Themeco license, I see that you have a Pro license but when checking your site URL, I see that you have installed X theme.

Basically you cannot validate X theme using Pro license. You will either need X theme license or you need to install Pro theme on your site in-order to validate it.

For detailed information, please go through our product validation guide here (


Thank you very much for your help.
I updated to Pro and I still have the same problem, any idea?


Hi @landerolabarri,

I went to your licenses page and see you added your website URL both for the production and staging version which is not correct. I removed the staging version at the moment.

Also by checking the front end of your website I see that you are using the version of 2.1.3 of the Pro theme which is old. Please backup your website completely and update the theme to version 2.1.6.

Another point is that it seems you are using the Jetpack. Please clear the cache and disable that plugin before the validation as the cache might be the problem cause.

After that, please try to validate your website using the guide below:

If you still have problems and there is a connection issue, it might be something related to your server which you need to follow and share the workaround below with your hosting service provider to fix the issue:

kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case if you still have problems.

Thank you.

I made the backup, I disabled jetpack and I cleaned cache three times in three different ways.

I can’t update the theme, the link you sent me is for X theme through Themeforest, I originally bought X theme, but now I updated to pro… I can not update it from there.
I tried to upload the last version (downloaded from my apex dashboard ) but it says there is a folder already with that name.


Hi There,

Please delete your old PRO first, to be safe please do it via FTP. You can follow the Manual X Update Via FTP guide that was provided here, it’s mainly talking about X, but that is also applicable to PRO (to any theme actually).

Hope it helps,

I updated it, but the validation still don’t work :frowning: I will see if contacting the host provider will do something…

Hey @landerolabarri,

Are you using the Converted license key or the original from Themeforest? You need to use the Converted one. If that does not help, please provide WordPress admin and FTP credentials in a Secure Note.


1 Like

Having the exact same issue.

We have been experiencing so many issues with Pro and X over recent months over about 10 sites, what’s going on? The licence is clearly being picked up but wont link to the site, meaning that we can not update via the site. It’s been weeks now.

Hi @Chedr

Please open a new support thread regarding your question, as we might need you to provide WordPress Dashboard login details and providing such details in Secure Note must be for the original poster only, if you did that on another user thread, the Secure Note will be visible to the original poster as well.


I contacted the hosting providers and they fixed it for me, it was a plugin that was conflicting with it.
The pluging creating the conflict was

Thank you very much for your help

Hey @landerolabarri,

Glad to hear you were able to get it resolved.

Have a great day!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.